TFT 35 + SKR Mini e3 v2

Hi guys I have a ender 5 plus I upgraded to SKR Mini e3 v2 earlier. yesterday I upgraded to a TFT 35, while doing so I changed to Kersey Fabrications marlin version for my screen and mainboard and machine frame. My Extruder wasn’t working without using M569 S0 E command then would give driver error. Now my extruder motor has stopped working completely expect for going back and forth. I tried switching out my X axis with extruder cable + driver and it didn’t startup but now when I tried to home my machine my X axis motor did the jitter like my extruder anyone know what might have happened?

Actually all motors are jiggling now

The first thing that crosses my mind is that the firmware is not configured for the type of stepper motor driver being used on your particular printer’s controller. Motors get the jiggles when the timing on the wires is wrong. Stepper motors must have the voltages applied to each of their 4, 5, 6, or 7 pins (depending on the motor model) in a very specific order with tightly controlled timing. Get either the order or the timing wrong and the motor will usually vibrate (or not move at all).

Check your controller board to find out what model of stepper motor driver it is using. If the controller board uses plug-in stepper controllers, check what model of stepper motor controller you have. Then go back into the firmware and make sure the printer controller thinks it’s using the same stepper controller. When they match, the printer controller will pulse the stepper pins in the correct order with the correct timing.

You may be literally one correctly placed (and removed) comment marker (#) away from fixing it.

Worst-case scenario, if you can’t identify the type of stepper controller you’re using and if you read the comments in the firmware and the default settings for an unknown stepper controller don’t work, you can just try each of them, one at a time, to see what works. It’s tedious, but not technically difficult.

Personally I have never done what you are trying. I don’t have enough experiebce to add anything useful other than is the board dead?

I will make a general comment, sometimes changes are not improvements they just make everything worse. People have always wanted to push forward rather than look back. Don’t forget you can always go back.

Hi There

If the motors are “jiggling” its usually because they are out of phase. There are 2 ways a motor can not work properly is that it can run in the wrong direction or it can be out of phase.


  • Be very careful to unplug your printer before you unplug the stepper motor. If you unplug the stepper motor when the machine is on you will fry your stepper driver.

that being said lets move on

If you look at your stepper motor wiring the actual JST connector is a 6 pin of which only 4 are populated. if you look at it it kind of looks like this, with the “W” being a wire, and the " * " being empty holes
W * W W * W

Now I am going to number these and it does not matter if you are looking at the top or bottom of the connector, Technically you could be looking front and back as well you just have to follow the pattern
1 * 2 3 * 4

From this point forward I am going to be ref the wires as the numbers above.

If you change the wiring so that it is now 3 * 2 1 * 4 ( invert locations for 1 and 3) the motor will now run the in opposite direction.

If you change the wiring so that it is now 1 * 3 2 * 4 (invert locations 2 and 3) the motor is not in a different phase and this is what you have to do to eliminate the “jiggle” most commonly this happens if you are using creality motors on non - creality main boards or vis versa.

I hope this helps