Bed sensor replaced and now Z won't zero properly

Hi All,

I just replaced a dead proximity sensor on a Creality Cr-10s Pro and now the machine won’t zero the Z axis properly. I have replaced sensors several times on other Cr-10 printers using the same parts and have not had this issue before. With the new sensor, the printer reads zero when the hot end is nowhere near the bed. The nozzle is anywhere from 10 to 30 mm too high.

I have tried manually adjusting the height and the results are the same when I go through the built in leveling procedures. I even tried flashing the firmware and there’s no change.

Has anyone had something similar happen to them before? Is there an easy fix I’m not seeing?

Thanks!
Jake

What proximity sensor are you using?

Can you re-set the Z offset to adjust for this error?

Hi CoitusMysterio,

I’m using a sensor from Amazon. It’s the same type as shown in this video:

Like I said in the original post, I’ve replaced a few of these on other CR-10s Pros that I work with and they’re running fine.

I managed to dig a ratty old sensor out of my tool box and tried levelling with it temporarily installed in the machine I’m working. It still says zero is several centimeters off the bed, so I don’t think it’s the sensor?

Hi Loosenut,

The z offset won’t let me adjust any lower than what the printer decides is zero. Tapping the down button makes beeping sounds but that’s it.

I’ve also tried turning the machine off and manually moving the gantry till the hot end is barely touching the bed. This doesn’t make any difference either, as when I turn the printer back on the machine goes back to zeroing way above the bed again.

Update:

I tried to adjust the z axis with no proximity sensor at all and the printer still stops several cm off the bed.

Is there any kind of Z axis limit switch still installed, I’m not that familiar with that printer.

Loosenut,

If there is a z limit switch, it’s not obvious. I can see limiters for x and y, but I don’t believe there is one for Z on this machine.

However I’m still learning so I might be overlooking it entirely.

If the ABL came installed on this machine then there probably isn’t a Z limit switch. My understanding is that usually the ABL becomes the Z limit stop. I had to remove the stop switch on my printer when I installed an ABL.

In some configurations there might be a Z limit max type setting that you have to update, i.e. it will only go down X mm beyond where it thinks zero is. This might be something in the firmware itself, or if you’re using something like Klipper in the config files. So it might be limited to going 5mm (or whatever the default setting is) beyond where it thinks and then stop and take that as zero. I would investigate that end of things. It might be possible to also set this directly via gcode … I know you can do this sort of thing in the CNC world but not sure about 3d printers.

Hi again,

Ugh… the situation has gotten more frustrating. After flashing firmware and updating the screen software, the printer now doesn’t turn on properly. The display screen looked fine as I installed the update, but now flashes the Creality logo for half a second and goes black when I try to turn the machine on.

Does this mean the motherboard or something inside is shot?

Jake