Big Issue suddenly appears

Suddenly my Creality CR10S pro is doing really weird things. It will not start a print, as soon as it gets up to temperature it immediately thinks the print is finished and starts to coll down. The BL touch flashes constantly. X- works but X+ doesn’t, Z+ works but Z- doesn’t, Y+ works but Y- doesn’t. Also there are some other weird things happening. I think this problem calls for someone with WAY more expertise than me!

Please don’t dangle “some other weird things happening.” in front of us and not tell us what they are! Now I’m dying of curiosity. Also, they might be clues.

The first thing I think of when someone says a print starts and stops immediately is an error in the GCode. If the machine encounters an invalid instruction, it will abort the rest of the print.

So, how to test for that: Try a print you have previously successfully made, or even one of the manufacturer’s demos. That should print successfully. (obviously, choose something small)

If that works, go back to the GCode that failed. Don’t re-slice it, just use it again. If it fails again, it’s the GCode. If it works the second time around, blame your cat. If you don’t have a cat, buy one and then blame it because I’d have no idea why it failed once but not twice.

So, assuming the GCode fails on the second attempt, re-slice it. Slicers are not perfect. They work 98% of the time, but every once in a while they produce garbage output; either prints that fail outright like yours, or prints that repeatedly fail (like a layer shift) in exactly the same place every time.
If you ever suspect your slicer isn’t having a hiccup with a particular model, simply rotate the model, even slightly, on the slicers build space. That will force the slicer to re-compute an entirely new set of paths and the problem will likely go away.

Now, I’ve gone down the path above because you indicated that the print started and stopped but didn’t indicate there were any error messages.

On my printer, if the printer fails to home correctly, I get an error message. I can’t speak for the CR10.

The fact that X-, Y-, and Z- don’t work (and I assume you mean “don’t work from the control panel”) implies that your limit switches are being triggered and the printer believes it is in the home position and, hence, won’t go backward in any axis.

That is very odd. The limit switches are on separate inputs. I can see one limit switch getting disconnected and, depending on the design of the printer, causing the printer to believe it was constantly being triggered, but to have this happen with all three would require all three to be unplugged. You didn’t work on the printer and forget to plug them back in, did you?

1 Like

I have tried still files that I know work so that isn’ The problem. Also I haven’t worked on the printer so that shouldn’t be a problem. I am stumped!

Hm. So, for further clarification: you can use the control panel to move each of the axes in the + direction. Once you’ve moved them in the + direction some noticeable distance, can you then move them back to the start, or does the - direction not work no matter where the controller thinks the print head is?

As you move any given axis in the + direction, does the display show the corresponding axis as having moved, or does is still say 0,0,0?

And, please, what are the "some other weird things happening.”

Creality CR 10S Pro

  1. All axis will go in the + direction and display the position, They will all move in the negative position to zero and display that but will not move past zero in the negative.
  2. BL touch flashes constantly
  3. Will accept a print, will accept temperatures for hot end and bed, will rise to those temperatures and the hot end fans work.
  4. Once the set temperatures are reached bed and hot end move so hot end is over the front left corner of the bed and displays that position on the screen. Then the bed and hot end move so the hot end is over the middle of the bed (this is all normal). The z axis rises.
  5. At this point all movement stops, the screen displays finish print, temperature of bed and hot end start to drop, percentage of print display and meter start to increase, BL touch continues to blink.
  6. Touch finish print on the display and the bed moves in the positive y direction and the print head moves in the negative x direction until the hot end is at the front left corner of the bed. (this is also normal)

Sounds like it wants to probe z home in the middle of the bed and the sensors not working.

This is completely normal. At this point, though, the print head should be in the corner of the build surface. On my printer (Ender 5Pro) that would be the right-rear corner. I don’t know what the home position on the CR10S Pro is, but by what you’ve written, it seems to want to put it in the front-left. The only printers for which -ve movement applies are the Delta printers which, in their resting position, have the print head in the middle of the bed. All Cartesian printers will use one of the corners. On a Cartesian printer, you can’t physically reach negative territory. The limit switches mark the 0 position and act as a physical stop.

In Cura, make sure Settings->Printer->Manage Printers->Machine Settings->Origin at Center is not checked.

Try one other thing, if you would: place a model on the slicer somewhere other than the middle. When you try to print it, does the head move to wherever you placed the model?

Beyond that I have no experience with the BLTouch. As far as I know, it’s supposed to do bed levelling before the print starts and as such should be testing various points (mesh levelling) before the print head moves to the middle to begin a print. Then again, I also suspect mesh levelling has to be specifically enabled and if not, only one probe is done in the middle which may be where it’s hanging up. So this could be entirely a BLTouch problem, in which case I’ll leave it to others to help you with.

at this point, the probe is supposed to deploy to probe the Z home.