BigTreeTech SKR MINI E3 v2.0 on CR10

Did someone been able to compile and flash a firmware for BigTreeTech SKR MINI E3 v2.0 board for CR10 (first version).
I have been working 2 days following steps on this video : Creality CR-10 How to mod your firmware. (BTT e3 V1.2 and others) - YouTube

This guy is working with a BigTreeTech SKR MINI E3 v1.2 and Marlin version 2.0.7.1

The latest version of Marlin is 2.0.9.1 and as i said before I am with v2.0 board.
The problem I have occur at minute 15 on the video when he is opening platformio to build the firmware.
I download platformio but cant see anywhere the work task tab. So I am just blocked there.

1 Like

So you have marlin downloaded and extracted in a folder you can find. Preferably in a more direct folder like my documents.

Open vs code, open the extensions tab on the left (the boxy one) and search for platformIO. (Orange alien head guy)

Optionally (and i havent successfully used it) but you could search for marlin and download the auto builder.

From the platformIO, select open project, and find your marlin folder (select the folder that contaons the configuration.h, configuation_adv.h and platform.ini

Traditionally these are the 3 main files you will be editing in vs code.

I havent compiled firmware myself for the cr10, but have veen playing around with it for my other printer. I can give some pointers as needed if you have questions :slight_smile:

I had a simmilar issue on the platform.io file. On my printer (mks robin lite v1.1) i had to input mks_robin_lite_v3, compile, then went back and changed it to mks_robin_lite and it was successful for me.

Specifically are you having a failed to compile issue? Or just figuring out your board/chip?

*Also made my previous comments prior to watching the video, but am now having a closer look at it

Hi Dr. Marvin
Thank you for your help,
I found another video that explain the same way you do. I have been able to compile again the firmware.
I have this message when i put my sd card in : ERR: Max temp: E1 Printer Halted, please reset. There is also a kind alarm noise.
I turned off the printer take out the sd card and turn it on. Again same alarm noise and same message.
ERR: Max temp: E1 Printer Halted, please reset.

That sounds like a wireing issue :S though sounds weird though.

So the firmware is compiled. You copied a “fresh” copy to your sd card? The file in the sd card has .bin

Try powering on the printer with no sd card. What happens. Dont start playing with the printer quite yet. If it powers fine, check the firmware on the printer as is. You can do this with pronterface though off hand i forget the m5xx number to check.

If its not your version you should have 2 options here. 1 unplug the printer from your computer and power it off, put jn your sd card with the .bin firmware file, and power it on. It “should” update. If not. Power off, pull the sd, power it up and plug it to your computer. You can use cura (i have used it on my cr10spro) or use vs code (i havent successfully used it to upload firmware but thats a different issue). Try uploading the firmware from the computer.

If this works, verify the firmware again on the printer, either from the printer itself (if possible) or from pronterface. Before you tell it to home, select the individual axis on either the printer or pronterface and verify they move in the correct directions.

If yes, then place eaxh x, y, z axis away from the endstops (like in the middle) and ask it to home. As it moves manually hit the stops. If it dosent stop, unplug the printer. If all goes well, then do a PID tune. Teaching tech has a good calibration tool website thing to calibrate the printer.

Also good thing to check is that it saves the eeprom. I only mention this as thats my current issue with my printer (unrelated to you)

If you still have the max temp error, and you’ve verified you have everything plugged in correctly. Hmm, we will need to figure out if its a shorted thermistor, or perhaps your settings are wayy out of wack?

What did you set for your thermister # and max/min temperatures?

Hi Dr. Marvin,
Thanks again for your help.
Just very busy for few days. I will come back to you for further developpement.
I will compile again the firmware and try to flash it with sd card another time.
When I power the printer with no card I saw Bugfix 2.0x Marlinfw.org just before the following message appear.
ERR: Max temp: E1 Printer Halted, please reset and alarm noise

I would avoid the “Bug fix” versions of the firmware untill your comfortable with what your doing. They are THE newest marlin versions, but can have issues that havent been worked out yet. Id go with a stable build lile 2.0.9

Just my $0.02

Hi Dr. Marvin

This morning I compile again the firmware following steps in this video :

The only thing I made is changing few lines in Configuration.h as describe in video 3

Line74 Change Ender 3 for CR10

Line 148 Machine name BTT-CR10

Line 1241 bed size to 300

Line 1242 bed size to 300

Line 1250 Z max pos to 400

#define STRING_CONFIG_H_AUTHOR “(BIGTREETECH, CR10)” #define CUSTOM_MACHINE_NAME “BTT-CR10”

#define X_BED_SIZE 300

#define Y_BED_SIZE 300

#define Z_MAX_POS 400

After success in the build process I tried to transfer firmware.bin to my printer with the fresh version.

Same problem : it show first Bugfix 2.0.8.2 then ERR: MAXTEMP : E1 Printer halted please reset with the alarm sound.

So, just return to this video:

The only thing I made is changing few lines in Configuration.h as describe in video 3

Line72 Change

#define STRING_CONFIG_H_AUTHOR “(Services3DRG)” // Who made the changes.

Line 146 Machine name BTT-CR10

#define CUSTOM_MACHINE_NAME “BTT_CR10”

Line 1358 x bed size to 300

#define X_BED_SIZE 300

Line 1359 y bed size to 300

#define Y_BED_SIZE 300

Line 1367 Z max pos to 400

#define Z_MAX_POS 400

After that I formatted my sd card a put fresh copy of firmware.bin

Turn off printer, insert sd card, turn on printer What I see now is : Marlin 2.0.9.1

Nothing else no possibility to clic button

Turn off the printer, take out sd card : What I see now is : Marlin 2.0.9.1

Nothing else no possibility to clic button

1 Like

Hi Dr. Marvin,

As you offered me to have a look to the firmware, I just sent you a link to the Marlin folder I placed on google drive. I hope you will see where is the bug

Thank you very much,
Roger

1 Like

Messenger @ Davin Cashew

1 Like

your firmware seems relitivly good, just the platform,ini board env, though dont know if that was my end being weird or not.

You have the lcd defiend correctly (assuming your useing the stock screen) So im not seeing any conflicts there.

Id say try uploading the firmware again, if it dosent seem to work well by sd, then try through the computer useing either cura or vs code.

Anyone else here framilliar with how to install drivers, particularily for the BTT SKR MINI E3 V2.0? I found them on the github but @RogerGaudreau and I arent sure how to make use of them. My experience was with my drivers being a simple .exe file so click and forget.

here is the github link. to download them you need to go up 2 branches i beleive and its to download the whole lot including the firmware.