BL Touch error during bed level

Ok so was having issues with my Ender 3 and the BL Touch so I brought it to 3D Printing Canada for them to take a quick look at. Of course everything worked fine there. Brought it home and starting a print probe deploys touches once re-deployes and I get a blinking red light when it touches.

Figured it’s noise related so I rerouted my wire away from the hot end lines and tried again… same issue but either on the first point or second point.

Not really able to drive it back to them again at 2 hours away with traffic.

Any ideas???

thinking the probe is getting stuck there is a set screw in the top of the BL touch if you unscrew it you can pull the probe out the top and clean it and check if it’s bent mine had a little flash on it. then try it again. 3Dpc sells spare probes too.

This is a brand new probe I havent even printed with the unit yet… sigh

Why would it work fine using bed leveling but when I go to print it errors out

If the touch is working to do bed levelling command but fails at the beginning of the print that sounds like firmware / or commands sent with the slicer.

Are you sending code commands with the slicer? Could they be conflicting with firmware commands?

What firmware are you using?

I would always suggest contacting whom did the mod. They should be better able to do tech support. To my mind this sounds like a firmware issue. It could be hardware but if it works for one type of probing and fails during another it seems unlikely.

What were you trying to resolve with the BL touch?

what start commands are you including in your slicer? Bl touch has its own built-in error checking the blinking red indicates the probe didn’t extend or retract in the allotted time

  1. If the red LED flashes to 80% duty during 3D printing, check the wiring of the red cable (poor wiring).
    It may be necessary to repair or reinstall the cable.
  2. if the red LED in BLTOUCH flashes at 80% duty right after the 3D printer is switched on,
    please release it with S60 or S160.
    It’s a message to check Wiring because your 3D printer board is already sending a control signal to BLTouch before BLTouch power is turned on. Don’t worry, your 3D printer and BLTouch work perfectly even if the Red LED flashes at 80% duty.

It is common for BLTouch control signals to occur at machine startup or a little later.

1 Like

I did the MOD.

I’m running the firmware from the creality site for the 4.2.2 board from Jan 28 2021 for the ender 3.

Friend recommended getting the bl touch so I don’t have to worry as much about leveling the bed.

I made the recommended change to the gcode in the slicer software.

Currently rechecked all my connections and started a print. It successfully checked all 9 points twice… I’m so confused…

Had to restart print as my offset was wrong this time it failed after point 5 second touch

OK The thing to remember that the touch can only correct very small variations. They say ½ the nozzle diameter max and 1/4 or smaller is recommended. You really need good tramming (levelling) done before you even start.

When it fails is it blinking?

You can ignore this if you wish. I debated if I would add this. It still seems like a physical error. I don’t know how long you have had the printer but if it is new consider removing the BL touch. Return the firmware and just do manual tramming (levelling).

It is a bit of a skill, and takes some practice to get right. The BL touch certainly helps but you add a tramming system on top of a tramming system. Having dual controls for one thing can get complex.

I can only guess your experience, if you are not adept at tramming I would suggest go back and learn the printer before you add the touch again.

Flour once was ground. Then roller mills were invented. The roller mills remove most of the food value from the wheat. Rather than return to grinding flour, that was seen as a backward step, so white flour is enriched chemically to return value to it.

Yes when it fails the red light starts blinking. Probe extended blue light on as the problem touches the bed it starts blinking and the the printer stops the leveling steps and starts printing.

In regards to your second post. I did multiple test prints for bed leveling and got it as Level as I could before I added the bltouch.

That sounds like firmware. I can’t say for certain, I am not a fan of messing with software. Perhaps @LEGOManiac , @Dr.Marvin or @Glenn will have better suggestions, or thoughts. If it does a bed levelling but fails on the pre print it is likely a firmware issue? maybe.

I don’t have the expertise to fiddle with firmware.

The duty cycle at 50% is what I’m talking about, looks like … flashing, at 90 % it looks like a slow flash with the light mostly on and only off for short periods. That 50% alarm happens when the top rail condition in the timing diagram is not met, The slope in the signal drop is the time it has to make the next condition, Timing is from left to right, and if the magnet on the pin is not in the right place (in the period where the dotted line is and the bottom of the slope) this alarm is the result. Also, BL touch can sense a lot more than. 2mm errors in height/flatness it can not tolerate twist in the X-axis though and if your bed has a 2mm divot in the middle the sensor will record it in the mesh but your prints are not going to come out very good. That being said it’s best to have it mechanically trammed as good as it can be ahead of letting it make its mesh. I can actually take the steel plate off and swap it for a piece of 1/4" thick glass and it has no problem with the change. I have a mesh saved for the glass and one for the steel it’ll probe 3 points then tell me the mesh doesn’t match and I can switch to the appropriate one or make a new one.