BL Touch installation - smoke and glue :(

Hello all!

I am finally trying to install the BL Touch that I bought months and months ago. I am already worried that I have fried the board - when I tried to turn the printer on with the firmware upgrade on the SD card, the screen never turned on then I saw a waft of smoke coming from the motherboard. I opened it and couldn’t figure out where it was coming from but after looking at the wiring I realized I had the connecter wires hooked up backwards. I should have taken my time with it but alas…

Another BL Touch installation guide mentioned that you have to disconnect the z stop connecter so as not to confuse the printer. That is also something I hadn’t done. I decided to do it before turning it back on again only to discover that it appears to be glued into place. Is this typical? It’s an Ender 3 v1 with a 4.2.2 board.

The connectors on the motherboard are typically hot glued to stop them from coming loose in shipping. You can just disconnect and remove the switch from the gantry support column and leave the wires on the MB alone. As far as the magic smoke coming out you will have to try it and see. If it is fried then check to see if that printer can take the 4.2.7 MB (I think it can) as it is more reliable and has silent steppers.

Ok good to know I can leave it. Thank you!

I think I may have also had the wrong firmware. So many mistakes. I changed to a different bin file and fixed the wiring issue with the connector… turned it on and the screen lit up and the bl touch is on! Fingers crossed. I haven’t actually tried to use it yet…

Hopefully the smoke was just a warning and everything is ok. We will see.

Only thing to do is to try a print. I’m not familiar with the V1 firmware, do you have one that supports a BL touch?

Yeah, Creality has an Ender 3 v1 4.2.2 board firmware file for BL Touch.

I am having a bit of a hard time figuring out what to do next. The z axis was way up high when I started the installation and now it won’t go down when I try to auto home or use the levelling with the BL Touch. Even moving the z axis with the move command isn’t working. I can move it up, but not down.

MB might be fried (magic smoke leaking out is not usually a good thing), someone else here might have a better insight about it then me. You can contact our host, 3DPC, and ask them for help. They are very accommodating that way.

I just tried the Z axis adjustment on my V2. It will go up from any point but will only go down back to the level it started on. It will not accept a Negative input and go below the start point. The only way to get the Z axis lower is to home it or home all. I don’t know if that is the same as yours.

Yeah smoke is definitely not a good sign for sure. :wink: I am not 100% convinced yet that it is fried tho since a number of other people have reported the same struggle when first setting up bl touch and managed to get it working. It seems as tho I should have manually levelled it and then installed. Weirdly none of the videos or articles I consulted explicitly stated that… and I looked at a lot of resources.

I was trying the auto home function and it adjusted the x and y but left the z where it was.

These two videos show how to install one. They are for the V2 but should be similar to yours.

Found this one for an Ender3

Thanks! These are all more or less saying the same thing as the other videos and articles. Though one of them does actually recommend manually levelling first, but the more I think about it the more I feel like the fact that I had the z axis up high shouldn’t be an issue. I have come across some complaints about the Creality version of the firmware for this, so I may try a non-creality version just to see.

I have also reached out to the folks at the shop to see if they may have some thoughts as to how to fix it… or maybe they will tell me that while my board is partly working, I likely have fried some component that controls the z axis.

I appreciate the time you have taken to help by the way!

I managed to make some progress. I came across a post on reddit that said that sometimes the z stop state is stuck in a ‘TRIGGERED’ state and that you can check this with pronterface. So I set pronterface up again (new computer) and sure enough it was in a TRIGGERED state. This person had also said that after connecting with pronterface the problem went away without even doing anything to change the z stop state… so i decided to give it a go again and had the exact same experience. It is def too high still but from what I understand I need to adjust the z offset anyway. At least the z axis came down from almost as high as it would go to just above the bed.


How high is to high. A couple of MM or 20mm???

If you are close then set the z offset should do it. The bed does have to be manually levelled and re-levelled from time to time as they do shift eventually. The z offset on my E3V2 is about .76mm. I would think yours should be a similar amount??? I could be wrong, i was once before.

Did you remove the Z axis limit switch.

I did remove the z stop and once it started moving down it was just a bit too high. Looks like my offset is maybe -3.2mm. Assuming I am doing things right at this point.

I seem to have gotten a step further now where it moves down now when I home it and do the levelling but it seems unhappy when it goes thru the points in the levelling. It randomly seems to error out while probing one of the levelling points. It does the quick flashing red signal light. I am wondering if the cable is damaged… I am not sure I would have gotten this far if I had really fried my board but maybe the issue is related to that…

You should be able to set the Z axis down to what ever you need by a control panel setting. I’m not that familiar with the panel on the V1 so I can’t help with that. You can also adjust the spring a bit higher as long as they are not to “soft”.

You said that you plugged the BL Touch in backwards even with the safety tab, no mean feat. Kudos.

If the contacts touched and they may not have been able to because the tab is suppose to stop the connectors from being connected backwards, It could have sent a power spike through the BL Touch, damaging it or routed one back into the MB where it shouldn’t have gone, again damaging it. The MB can be damaged in a localized area and still have a lot of it’s functions left. Possibly the connector was damaged when it was inserted or removed.

You could unhook the BL Touch and see if the printer works properly with out it. If not then you probably have a MB problem. Magic smoke came from somewhere.

The cable I got didn’t have the tab so it was quite easy to plug in the wrong way. No super strength needed ;).

I will try removing the BL touch and see what a print is like on the weekend.

No super strength. AHHH And here I thought you would have an outfit with a cape and mask to work on your printer.

If you haven’t removed the Touch yet then you can just remove the wire connect on the touch instead of going into the Motherboard again. Easier to put back on to.

Oh I definitely wear a cape when I print all the time. I just didn’t need the super strength this time around :wink:

Disconnecting was the plan, I shouldn’t have said ‘remove’.

Fingers are crossed again!

generally speaking smoke = not good. Let us know how it goes, hopefully, it was just a dust bunny in the wrong place at the wrong time.