Btt skr mini e3 v2.0 - Need help before i go crazy

Hey everybody!! :slight_smile:

I bought two btt skr mini e3 v2.0 for 2 of my ender 3 … it’s supposed to be plug n play, but like anything in my case it isn’t. lol

Firmware does not update … Whether it is a freshly compiled version or a pre-compiled one found on the web (like that of Btt or Marlin), it does not install.

I went through all the usual procedures.

-I have tried different SD cards of different formats from 1gb to 32gb
-I tried to rename the file in several ways, including the classic firmware.bin all lowercase.
-I have tried different firmware versions / compilations
-I had some fresh versions compiled by a friend of mine who is relatively very good at it. He even compiled the Marlin version without changing anything, and it doesn’t work anymore.
-I went through EVERYTHING written here:

-After flashing the printer, the file on the card does indeed become a * .CUR but it still does not work.

My problems, depending on the tests I made:

-The firmware does not install at all. I stay on marlin Bugfix 2.0.X after flashing. No update has been done.
-The firmware is malfunctioning, the autohome is not functional and we are unable to pinpoint the problem.
-The printer starts up, the Marlin screen appears and everything freezes on the Marlin screen.

We are three people to have covered the problem. We are at the end of our resources …

From what I see on the web, and in the link I put, we are several to have had this kind of problem.
Some say to see with Btt service, they ask for a video of the problem and will refund the Skr… Others have solved the problem by themselves …

We cannot find a solution for the moment.

The Btts were purchased here from 3d Printing Canada.
So I was wondering if the problem was known, or if someone happened to have a stable Ender 3 or ender 3 pro compilation that I could try …

I’m seriously stuck

Thanks in advance!! :slight_smile:

I would have to admit, thats a good one, I just pulled one out of inventory and had a look to make sure they are not doing anything stupid like setting the reset jumper out of the factory. that is not the case here. What I do have is 2 E3 V1.2 boards and can change them out for you. older board only diff is that it does not have duel lead screws outputs but if you dont need that at least I can guarentee they are from a different shipment . Just a thought

1 Like

Thanks Jason

I found a way to make one work. I’m stuck on Marlin bugfix, but everything works fine.

For the other, I am trying other methods with a friend. I’m almost there, but we’ll have to rework the compilation again.

I tried to contact BTT, but ouch … The only thing they do is give the same info in a different way over and over through their email. Looks like they are ignoring the problem on purpose.

If I don’t get through the second one, I’ll let you know Jason. Thank you very much for the offer !!! Much appreciated!!! :slight_smile: :slight_smile:

I personally like BTT gear, but with the volume of boards they are producing and the chip shortage I am not sure if that may be having an effect on Quality. again I really do like the BTT boards but what’s going on in the news does kinda get you thinking.