Can't seem to fix underextrusion

I just got my Ender 5+ back from shop, they replaced the board as this was apparently the cause of my extruder not working. First print was beautiful…somehow the bed was jarred or something…not sure but the leveling was WAY off…I eventually got it releveled and it seems to be printing but now it is under-extruding.

I have checked for clogs, used cleaning filament, did a cold pull, then removed the nozzle to clean it and NOTHING makes any difference. Its was printing this same filament at these settings beautifully a few days ago (i even tried a new roll in case of humidity) and nothing I do seems to make a difference. I print an XYZ cube and it crumbly to just slight pressure and the layers peel apart easily.

Getting frustrated and don’t want to have to bring it back again so soon. Hoping for some suggestions?

Hi Kris

Is it making any clicking sounds?
Is this is a slice you have printed successfully before or is it something newly sliced?

no noises…yes a calibration cube i’ve done before several times as well as I had first tried printing a filament spool holder after the first print when i discovered that was under extruded. I’ve tried everything I can think of. I literally just got it back from the shop after it took 2 weeks to get repaired and really would prefer not to have to bring it back in again.
any suggestions?

that does seem like a weird one, I would sooner avoid you having to bring it back as well. Can you send me a copy of your M503 output so I can make sure nothing reverted back to the factory? Do you have a direct drive on it?

I had under extrusion happen just recently and found my e-steps for the extruder were way off. Mainly because I had upgraded my hot end and it required a higher value.

I just did the esteps and they were WAY off…I am confused how that happened bc the first print when i got the printer home was absolutely perfect. I have corrected the E-steps and it seems better but still not as smooth a first layer as it had before. I am running a longer print now. The test cube worked but was a bit rough…however i did print it on the fastest setting/lowest detail so I will see how finer detail prints work. What could cause it the esteps to suddenly go off so badly? I’ll get a copy of the M503 tomorrow and send along.

Hey @hawleyk

that’s what I was afraid of, we do the test prints here in the store and everything tests fine, “sometimes” and I cannot figure a pattern to it, best I can describe it as random. the old settings go back into the firmware.

From what I can test here it has something to do with the eprom.dat file on an existing SD card, The control boards currently in use commonly store all of the EPROM data out onto the SD card and read it when doing a print. It’s supposed to be a one-way street unless you make changes. It reads from the control board to the SD card and is basically a cache for firmware settings. When you make a change say esteps, it’s stored on the SD card and does not get written back to the control board until you select “save” in the control menu. Essentially the same as an M500.

Randomly when you put in an SD card from another printer it will transfer these .dat settings into the current printer and use those as current settings without actually reading the current config off the EPROM to say what is right or wrong. The M503 is a way to tell what the printer is actually looking at when it’s doing a print. If your first layer looks wrong its probably because the Z offset is now incorrect as well. The M503 will be the key to finding what settings got messed up.

Default esteps should be somewhere about 93, Origional Microswiss is around 137, the NG is about 400 range, if you have a .9deg motor installed instead of the standard 1.8 deg you can double all of these numbers.

It will at least put you in the neighbourhood.