CR-10 Pro V2 - BL-Touch Blinking - Pin won't drop

I recently cause a failure in one of my prints.

While the machine was going through its pre-print measurement process I attempted to remove some filament from the tip of the hot end with some long nose pliers.

I ended up accidentally knocking the BL-Touch pin, and bent it slightly which then prevented it from retracting.

I immediately tried to stop the print through the menu but the printer kept going through the process and started to try and print even though the height of the hot end was too high.

I decided to turn the power off on the machine.

When I turned the machine back on the BL-Touch was blinking. I tried to home the printer and go through the levelling process but the BL-Touch Pin would not drop.

I have tried running print jobs and the printer goes through the process of preparing to print but the printer shows the print job rapidly moving through progress % and eventually shows that the print job is done without actually doing anything.

Looking for some suggestion on how to get my machine working again.

Replace the pin and hope the touch isn’t damaged.

I don’t think there is anything wrong with the Pin, but I will try that. I straightened the pin after knocking it. I have gone through a cycles where it drops and retracts. I thought I close to fixing it but then it reverted back to not working

The pin on the BL touch is designed to take a hit and bend, it is replaceable for that reason. If it is operating like you said it is probably OK. That doesn’t explain why the printer is not working right. You can disconnect the Touch and see if it prints properly that way. If it does then the Touch is the problem, if not then it is something else. You need to eliminate each potential problem one at a time so you can isolate it.

when you power on the printer the pin has to deploy and retract 2 times, if not it’s binding in the throat somewhere. If it does not deploy and retract on boot up it it will start flashing red and error out.

1 Like

Ive gotten this sometimes on my printer. Though ive changed the firmware to something from tinymachines and theres an option to reset the the bl touch, which usually clears my issue.

1 Like

Forgot to follow up. In my case it was a pretty a simple fix. I thought I had adequately straightened out the Bl-Touch Pin but when I removed the pin from the housing, it was still bent. I carefully straightened out the pin and I no longer get the flashing red light on the BL-Touch and the pin drops as it should upon start up. Still have to do test print, but that seems to have fixed the problem.

2 Likes

@TrueNorth thanks for letting us know, Thats awsome, simple fixes are great, they are just not that common :wink:

1 Like