CR 10 SMART not reading SD card

Hey guys
so I recently got myself a CR10 Smart from 3d printing canada and it seems like the printer isn’t reading files from the SD card. I’m using the front sd card slot. It shows nothing. If I plug the SD card into my laptop, I can see all the presliced files but in this case, none of them appear on the LCD. Starting to wonder if it’s broken or a firmware issue. (BTW this printer is refurbished from 3DPrinting canada)

I’m also able to print via wifi but that’s my only method of printing rn

Creality limits the amount of characters that will show up on the screen, try shortening the names of the files.

make sure you put the card in with the contact tabs up. Sounds like you might be putting the card in upside down. If not I would try a new card.


Do you know what that limit is?

I tried with around 2 micro sds using the same SD card adapter. still no luck. I did it with the contacts up too

names are around 6 letters

I think 16 characters.

1 Like

I believe it’s 8 character name and a three character extension separated by a dot.

The old PC-DOS file name format.

I don’t think having a long file name will cause it not to show up. My Cr10 smart pro will truncate the filename if it is too long. I assume that the printer did not come with a full size sdcard like it did new.

I have had a couple of micro sdcard not show any files when put into the printer. They were cheaper no name sdcards. The brand name one show up fine with an sdcard adapter in mine.

not sure if they have a size limit I have only used up to 32GB sdcard. it may be that the printer does not read over 32gb. the printer new comes with a full size 8gb card.

acording to creality the 8gb card
“Format the TF card on the computer, and select 4096 to allocate the size of the unit.”

Blaze, since you have a creality cr10 smart pro can you tell me what your e-step setting is default.
you get to it by going to settings then advanced settings then movement then steps (if I remember correctly)
Thank you

I have the CR 10 smart, not the pro variant. also i will try to use a full size SD card and not an adapter. I am also formatting it with the 4096 byte thing and the sttings they recommend.

Hey guys
Just tried, it’s not working… Any ideas?

After a few years my cr10 pro v2 sd slot got tired so rather than mess with repairing it , I use octoprint with a raspberry pi …this works great :slightly_smiling_face:

The card must be formated in FAT32 format. If it’s a high capacity card, you could always do a smaller partition on it and than format it as FAT32.

Hopes that solve your problem, I had this problem at first on mine

Tried that a few times, used 8gb, 16 gb and 32 gb cards

1 Like

I had a problem with my sd card {on my laser, not my 3d printer} turned out there was to many files on it. It was by no means full, just to many files.
Could try that.

There are no files on it

Do you have a 1 GB card you can use? (as everyone’s pointed out, FAT32, 4096 for alloc. units. Make sure there’s no folders on it, and put a single file on the card so that if you ran a cmd prompt it would have a file in *E:* called mytestprint.gco or mytestprint.gcode depending on your slicer. (your drive letter may vary).

Dial it back to the simplest measurable input you can. 1 GB cards will hold a number of sliced files, and generally they are super cheap or have served us well and owe us nothing in this day of larger SD or microSD cards.

If that still gives zero on the list of files, look at the firmware version of the screen, and the firmware version of the motherboard inside the chassis - don’t rely on the screen to tell you what the mobo’s version is. using that trusty 1 GB card, after you remove the .gcode file, flash the mother board and then flash the screen following Creality’s guides with the latest firmware that’s appropriate for your hardware.

If you’re not comfortable with that, open a support ticket with 3D Printing Canada. They are responsive, but do give them a day or two between emails to catch up as they can get pretty busy. The CR10 Smart doesn’t like anything over 8 GB according to the manual’s for the one I had but ended up returning due to issues with the screen not responding to touch, even after repair - I moved up to the CR10 Smart Pro as a result, and with the back and forth with Msav, and my own thinking process, it’s now giving me a good first layer again. Now, to print that fallout mask for a friend… :grin:

I tried to flash the firmware on it by turning off the printer, inserting the SD card with the firmware, turn the printer on and hold the silver button on the right, but it doesn’t seem to update the firmware.

For the main board FW update, you did hold the silver button on the side down for the entire process right? Once the display completes and shows you the menu, (assuming there’s nothing wrong with the display as it’s an entirely diff. mini controller system) you should be able to go into Settings-About - and get the firmware - sorry, running off memory on how that menu’s laid out and well, it’s foggy in my brain.

Alternatively, if you can, look at by Yasmeen Yarkspiri’s tutorial on cutting out the Creality Wifi box built in, so you can talk to the main board directly using OctPrint (or Octopi if you have such a beast setup). You can probably use Pronterface as well to talk to the mainboard and get firmware info out it from either of those. The nice thing about what Yasmeen is suggesting, is you can revert back with no issues to stock if that’s the way you want to go.

Yeah I held it for the full process. The boot time is the same as without holding it. I think it’s the SD card port. I’ll get a USB cord and connect it to the usb thing.