CR-10S Pro V2 Extruder skipping


I bought a CR-10S Pro V2 last year. The extruder motor is skipping steps. It is the extruder motor that is skipping. I can see that the filament is not slipping between the gears. It has been 2 months of troubleshooting since the problem started and I can’t fix it.

I am using the same exact Gcode file and filament (PETG) that worked well for a few months. Here are the steps I tried :

Cleaning nozzle
Installing a new nozzle (tried 0.8 and 0.4mm)
Changing Bowden Tube for capricorn
Clean hot end with Bowden Tube
Make sure bowden tube is well seated in hot end
Make sure that the flow rate is right (checked with calibration cube)
Reduce print speed
Increase temperature
Change for a brand new filament roll

Nothing worked. Is that a known issue?


HI @FAllard

Welcome to the forum, Glad you found us in our corner of the internet…

This is actually a really good question and I would have to say it’s pretty typical for most printers. It’s not something specific to the CR10 or even creality printers. It is something that will happen to any printer at some point in time.

If you don’t mind I will use this as a bit of an opportunity to do a bit of a troubleshooting document and show everyone how I would troubleshoot this in my printer.

I know you have already done some work on this to work out the problem but to be complete about it I may touch on some things you have already done. As you work through this list you may be able to skip some steps as you have already completed them but this will be an opportunity to recheck anything you have already done.

I generally play the elimination to complete troubleshooting so first things first, Let’s eliminate the extruder as being part of the issue. Unscrew the bowden fitting from the top of the hot end. Heat up the nozzle (you will need this because the extruder will not work unless the nozzle is up to temp.) Once it’s warm Extrude 100mm of filament from the console of your printer. This will not be exact at this point but you can judge roughly if you are extruding 100mm of filament, 10mm or 500mm. If this is roughly correct you can move on. If not double check your esteps on your setup and let us know the result.

Now with the previous step complete, assuming successful you have eliminated the extruder motor, Bent or collapsed bowden tube, and broken or disfigured bowden fittings. Also at the same time you have heated the hot end and exposed a direct path from the top of the hot end to the nozzle.

Grab a meter of similar filament (cause we all know were have lots around :)), feed it by hand directly into the top of the hot end and see if by using moderate force you can push the filament all the way through the nozzle and have it come out at an even rate. If you cannot get it to go easily this confirms the problem is in the hot end.

Next part you need to look at is what part of the hot end is bent or broken, If you have made it this far it’s usually 1 of 3 things. Deformed nozzle, bent heat break or hardened plastic in the heat break.

Next step is pull the nozzle out of the hot end and push the meter of filament through it again, I generally do a different colour just to see if a chunk of old filament comes out. If you can push this filament through with no resistance (there should be none at this point) then the problem is in the nozzle, replace and retry pushing the meter of filament through it.

If you still feel resistance after pulling the nozzle the heat break is your cause, I generally will not clean them and try to “salvage” them, Cost is usually under $10 and does not make it worth your while to work at it.

Let me know how this guide worked out, especially if you are still having the problem we will try a different avenue.

I had a similar problem with my V1 of the machine. The bottom teeth of the extruder gear was digging into the arm of the extruder. Replacement part is pricey, so I just filed the indent, see pic, deep enough for a washer and all is good now.


Thanks a lot for the detailed guide!! I have just done the tests, here are the results. The guide was clear and easy to understand.

-Unscrewed the top bowden fitting, heated up the hot end. Extruded 100mm, I measured and it is very close (97mm). No skipping. When it does skip while printing, it is very easy to see and hear.

  • It was quite easy to push filament through by hand with the nozzle (0.4mm) still installed.
  • Removed the nozzle, pushed filament through the hot end. It was very easy.

I noticed that the hot end, the part where the nozzle screws into spins very easily. Seems loose. Is that normal? I can’t screw it in more, because of the wires going into it.

I started a print after doing these tests. After finishing the first layer (about 10 minutes printing), it started skipping again. See video. Same Gcode file that was working well before.

Thanks for your help, much appreciated!


I inspected the extruder assembly and it looks OK. Did you need to disassemble it to see the problem?
See video in my answer to Jason for a view of the extruder assembly.

Thanks for your input!

no extruder is ok at this point, we mostly eliminated that in the first test.

You did stumble across something most important though.

The heat break should not be loose at all and could easily be the source of the problem.
I have a link of a video here let me find it… (shuffles though papers on desk…)

Ahh, here it is

Its a little bit of an older video but the parts and theory is still approprate. If you hot end differs slightly visually don;t worry, The main points are still there and may have to adjust slightly for your particular printer. The heat break and nozzle must be tight always. and don;t forget to heat tighten the nozzle.

Now once that is complete test again and see if it changes, Ideally problem will be resolved but note if its not does the failure start at roughly the same point, earlier or later…

While you are looking at it verify all the fans on the hot end are working, specifically the cooling fan in the front. If everything is working well upto now then go ahead and run the 100mm extrustion test with everything assembled and let us know the results. If the extrustion test is low/short try it again without changing anything except drop the speed of the test by half and see if that changes the result.

If its still not working correctly we can go down the road of temp tuning.


I disassembled and reassembled the hot end following the video instructions. All looks good now. The hot end is now tight and not spinning easily as it was before.

I started a print again, and it started skipping halfway through the first layer (so earlier than last time). It did not skip as bad as the video I sent, but from experience it usually gets worse as the print progresses.

100mm test looked good. I made a mark with a Sharpie at 100mm from the entrance to the extruder assembly and it stopped within 2mm of my mark.

Thanks again!

ok, perfect, more and more info I love it.

is this a new file you sliced or is it something that has been printed successfully before?
Have you updated or reinstalled your slicing software?
What slicing software are you using?

if you still happen to have a file you sliced and you know works would you be willing to try it and see if it skips as well?

At this point with the line of questions, I am leaning toward either a filament issue or a slicer issue.

Mechanically your printer is good, 100mm tests are good and the nozzle is solid, does not appear any blockages anywhere so the filament path should be good. esteps are good, I can safely rule all of that out. at least for the immediate.

I am using Creality Slicer. I haven’t updated or reinstalled it recently.

The last 2 tests were done with a Gcode file that I know worked before. It is a part I have printed around 10-12 times over the last 6 months. I use the same Gcode file that was working before. I sliced it 6 months ago and reused the same file since.

I also did a few Benchy print tests in the last few weeks, tweaking some parameters in the slicer (temperature, speed, retraction) and it always ends up skipping at some point during the print.

I am using eSun PETG filament. When I started having the problem a few weeks ago, I changed for a new, unopened roll of the same filament. That is what I have been using since then.

ok, perfect, What temps are you printing at with this filament and what are the speeds?

Temp : 225C.

These parameters were working well before.

The first time I had the problem while printing, I tried increasing the temperature and reducing the speed during the print, directly in the adjust page on the printer.
I slowly increased temperature, up to 245C. Decreased speed to 50% of the slicer’s numbers. The skipping seemed to happen less frequently, but never stopped completely.

It is hard to tell if the adjustments are helping, because it is semmingly kind of random. Sometimes it will print ok for a few minutes, then start skipping alot for 30 seconds etc…

No disassembly needed, the paint would be scrapped off under the gear, metal filings could be present also. see arrow in snapsho

What are your retraction settings? Your motor could be skipping on retractions.


I could see some metal filings around the gears, so I took it apart. Here is what it looks like

Looks like it is rubbing… Did that cause skipping on your machine?

Here are the retraction parameters. It is skipping while pushing filament forwards. See video in one of my previous posts.

esun Petg, temp seems a little low to me, I would personally be doing about 240 as a start point. Did you do a temp tower for this filament.

The randomness of your clicking is what is tripping me up here on this. If you are looking at the printer when it fails what is it doing or what did it just do?

What I mean is if you are doing a long constant straight line does it click toward the end of it?
If it moves from place to place really quickly (without printing in between, like you were printing a bunch of towers) at that point does it stop clicking?

I am wondering if you are just at the cusp of melting temp on the filament and the heater cannot keep up. Raising the temp would help to narrow this one down. If you raise the temp and then clicking slows or stops then it’s temp. If you are doing a bunch of movements between prints giving the hot end a chance to “store” some heat and the clicking stops for a short time and then comes back, that would be it for sure.

For kicks, see what happens if you set retraction speed to 35mm/s.

Yes that is what mine looked like, but I did not have the machined step as you do. the machined step and washer is supposed to fix this problem. Was there a washer under the gears?

Hi, ive read that low voltage at the drivers can cause the skipping.
Easy to check if you have uart settings to view voltages in the settings or you may have to turn machine over disconnect motors from board and use a multimeter to check voltage of drivers. I would watch s9me videos on how to check voltages of drivers on youtube or somewhere.

Hi @Uncled

Welcome to the forum, Glad you found us here.

That is some very sound advice. Low amperage can cause skipping easily, the hardest part is always finding the balance of no skipping vs too hot a motor.