CR-20 Pro "Stopped" error

Has anyone come across this error before?

Stopped Error

Any solutions to clearing it?

Do you have any other information about when this issue happens? Does it always happen when doing the same thing or is it random? Have you recently changed anything on the printer?


Hey Matt, thanks for the reply. I get this message when I turn the printer on. I received the printer as is and I’m attempting to revive it into working order.
I downloaded the firmware from the Creality website and flashed the board but I still get that message.
The other strange thing is when i try to Auto Home, the Z Axis keeps going up, never returning to the bed.

Regards, Len

Hmm thats a head scratcher for sure,

Does it have a BLTouch on it? Seems like the z-limit switch/ bed leveling probe may still be triggered after it is raised. If it is a limit switch just press down on the limit switch and home it again while you are pressing down on the switch, if it goes properly then you know the switch is inverted. If it is a BLTouch let me know and we can troubleshoot from there!

Hey Matthew, yes it does have a BL Touch onthe printer.

I don’t believe that the CR-20 Pro has a Z-limit switch.

Thanks for your ongoing help!

BTW, here is the Start G-Code from Cura…

M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk
M220 S100 ;Reset Feedrate
M221 S100 ;Reset Flowrate

G28 ;Home
G29 ;Auto Home X,Y,Z Axes
M420 S1 Z2 ;Enable ABL using saved Mesh and Fade Height

G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up
G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up

Yeah if it has the bltouch it wont have the z-limit switch.

When you turn the printer on does the probe deploy and retract a couple of times properly?

It appears to deploy and retract as it should when I turn the printer on. I am also able to manually deploy/retract the probe and self-test the BL Touch from the Menu.

BTW, I swapped out the Z-Axis cable to test if it was the cable… no joy. I then pinned out both cables and they pin out okay, however I did notice that at the motor connector the center two pins are reversed, see picture below. Both cables are the same, so I assumed that wasby design.

You are correct, this is on purpose. The creality steppers have the inner 2 pins reversed for the polarity.

This is a tricky one for sure! Where have you been sourcing your firmware for these printers from?

This is funny, I think I found some firmware that we compiled in house around 5 years ago :laughing:

Not sure if you have tried this one but it could be worth a shot, it was good enough for us a couple years ago so hopefully that still holds up now lol.

I got the Firmware directly off the Creality website.

I did find a version of firmware called CR20-ProMarlin1.1.6TFBLtouch.hex that was referenced in a CR-20 YouTube video published by 3DPC. It didn;t work for me. I’ll try the one in the link you sent and let you know.

Yeah give it a shot, this is the most recent one we have produced to my knowledge (and quite honestly it wouldn’t surprise me if this was the most recent one overall)

Matt, I flashed the firmware, unplugged the USB from the printer, powered it up and tried Auto Home.

It auto-homed the X and Y axes, raised the Z axis, deployed the probe twice leaving it out the last time and the sensor light is blue. After a bit, it bounces back to the Info screen and shows a STOPPED message…

Stopped Error 2

So it seems to indicate something is wrong with the Z-Axis. If I try to manually move the Z-Axis using MOTION-MOVE AXIS-Move Z-Move 10mm, it shows “Move Z: +010.0” even thought it currently sits about halfway up the gantry. If I spin the knob to lower it, it will go to +000.0 and no further.

When I attempt another Auto Home, it auto-homes the X and Y axes and only raises the Z-Axis a bit more.

If you do this auto homing and then hit the bltouch with your fingers once it deploys does it make the error message go away?

Hey Matt,

Well I don’t know what happened overnight, perhaps the Creality goblins came and mucked about with the printers. Yeah, I’m actually working on two CR20s, each with their own issues. So here’s the skinny:

.there is no “Stopped” message on the info screen, huzzah!
.BUT when I Auto Home, it fails displaying the follwoing message…

CR20Pro-A Y-Axis not moving

On this specific printer the Y-axis does not move. I’ve replaced the cable, motor and limit switch, no joy.

BTW, when you asked about tapping the BL Touch after autohoming, it didn’t really do anything. As well, when I try to move the Z-axis past zero into the negative, it stays at +000.0. I know with the Creality firmware you can turn off soft stops. I can’t find that in this firmware.

Wow this one really has me scratching my head. Without being able to be hands on with it, it can be difficult to figure out where some of these issues lie.

If you are local to the store would you be open to bringing it in for service?

That would be an ideal option however I’m a pensioner and money is tight at best of times. I was hoping I could troubleshoot these issues withour having to spend too much.

I do know that I need a new limit switch on one unit however when I repaced it with a working switch I still could not get the Y-Axis to move.

Did you check if the y-axis limit switch was inverted as well?