Creality CR10S Pro Pause at Height

I tried using Cura’s pause at height, to change filament colour.
It went through the motions but restarted instantly, no pause for user input.
Do I need to use the repetier or RepRap version of this, do not what language the printer uses.

There is also a change filament script in Cura. Have you tried that? The change filament script doesn’t work on my E5Pro but the Pause at height does. Maybe the opposite is true for you.

If not, have you checked Creality’s web site for a firmware update?

Thanks for the tips, will check out both.

Just an FYI to all, CR10S pro comes with a Marlin type firmware.

Your CR10 might already know how to do this on its own.
The version of Marlin that came loaded on my Ender 5 recognizes the M600 (change filament) command, so I just edit it into the gcode file. Cura puts comments in the gcode that identify the start of each layer, so it’s pretty easy. The only thing you have to keep in mind is that the layers in the gcode file start numbering from 0, while the preview in Cura (where you’ll be looking to figure out when to change the filament) starts at 1.

Especially if you’re changing filament within the first few layers of a print, have a strip of paper ready. Place it under the nozzle, then when it starts to purge the old filament, gradually pull the paper away, so that the filament doesn’t build up at the nozzle.

2 Likes

Personally don’t use cura you should download preuss’s slicer so much more advanced in works like a charm

Some seriously good tips. Thanks!

The filament change addin does not work with CR10S Pro, this is a RepRap code and Marlin does not recognise it. Ran a test print and it just did not stop. Using most recent version of Cura (4.8).
Also CR10s does not have a button like ender 3, maybe I have to touch pause on the screen to stop when it does cycle through the ‘‘pause at height command’’.

I posted your question to the Facebook Multicolour 3D printing group I’m part of. They confirmed that the CR10S uses marlin firmware and that the Pause at Height does work If it is enabled in firmware

Dean Leedom, who posted this, says it has worked on every version of firmware he’s had since 1.1.9.

I have firmware version 1.60.9 and just ran ‘‘pause at height’’, code below.
image
It does the pause, move, retract and then just goes back to printing. This is from Cura 4.8.
Also found out from Marlin site that M600 requires an LCD controller, which the CR10S lacks, just a touch screen.


So still no farther ahead, even with all your guys help but I do have a pause button on screen and it moves the extruder away and shuts all heat down untill I hit print again. Seems a tough way to do this but I will keep looking for options.
Thanks again to all.

Just curious if you know if they have a cr10s with the controller knob. That may be the issue I am having, code does not work with touch screen.

Maybe give prusa slicer a try you can add the M 600 wherever you want

Problem lies within the machine, lack of control knob, not code. Code does not recognize touch screen as a viable alternative to reactivate print.

in Cura, when you use the Pause at Height post processing extension, the dialog lets you customize various settings, including the standby temp. It defaults to 0, but when I use it I set it to the desired temp so I can pull the old filament out.