Cura Printer speed: sub-timings

i have Flsun v400 , rated at 400 mm/s; the supplied manufacturer printer profile for Cura defaults to 400 mm/s for overall printer speed ;
all the other sub-timings (expert mode) have their own defaults (a lot less than 400);
i prefer to print that printer at 200 mm/s trading off speed and quality (along with layer height);
what i have been doing is halving all the sub-timings in Cura because i was halving the overall speed;
But, i notice that when i change the default 400 overall speed to 200, the other sub-timings do Not correspondingly change, so i change them manually;
should i leave all those sub-timings the way they were ?

(( i do specify the travel speed at 400))

the way I would do it is to set your “print speed” at whatever you want your MAX to be.

For all other settings I run at %, If I want it to run 2X Print speed, I set it at 200%, and Half of my print speed would be 50%.

This way you only have to change one value and everything else changes on the next slice operation.

just double-checked this:

Cura ( v 5.3.0) has a “print speed” top-level setting and sub-speeds, wall, in-fill, etc

when i change the top-level setting from 400 (my printer profile) to 200, none-of the sub-settings change (expert mode);

what i have been doing is just manually halving all of them excepting travel-speed (left at 400); then a slice gets 5 hours 37 minutes;

ok, then i go back and halve the top-level setting to 200; leaving all the sub-speed settings untouched;

slice yields the same 5 hr 37 min;

so…that top-level setting , by itself didnt do anything

ok, now let’s repeat this series of comparative steps by adjusting only the sub-settings and leaving the top-level setting at 400;

i changed all the sub-speeds back to their defaults ( per my printer profile)l

slice = 4:26

ok, now halve all the settings (that should mean lowering the overall , effective speed);

slice : 5:37 ( matching first steps above)

so it seems that altering the top-level setting, by itself does nothing and Does NOT correspondingly reset the sub-timings; that has to be done manually to make any difference;

that , to me, is a bug in Cura

on further thought , i guess halving the in-fill speed is stupid

even that still does not add up with the changes you made. I would agree it’s a bug you are seeing but surprised not more people are seeing it.