Cura won't open

i’m trying to download the Cura program but it won’t let me open it downloading it i have no problems i’ve even tried downloading older versions of Cura but still nothing works. mesh mixer and blender work and open fine on my laptop but for some reason Cura is giving me a lot of issues. Is anyone able to help me out with this.

Hi Duckyd

Welcome to the forum, Glad you found us. I can say this is a new one for me. Usually, it will produce some type of error to tell you there is a problem.

because It will attempt to directly access the serial ports I would have to guess it’s a security or access thing.

Right-click on your shortcut for Cura and select “run as administrator”. Give that a try and see if it works. If not open your task manager and try to start it again, See if the Cura.exe file pops up, if even for a second and let us know.


I am new to the forum so if I am in the wrong place to ask this question, please redirect me and I will move along… I have been using Cura on my PC for about 3 months and sever thousand files accurated translated and printed on my CV2pro. Suddenly, the software will not open. I have restarted then deleted all Cura files - then restarted, then re-downloaded - then restarted and nothing except the opening blue logo. I have installed the software in its own folder C: Ultimaker Cura - nothing/same freeze. I have tried another computer in my home and the same thing is happening. I have restarted my Hub (twice) Nothing. I am wondering what changed from yesterday’s succsses. Any thoughts out there? Thanks Forrest


Hi @forrestkhaag

If it was me I would check the windows event viewer. I would suspect windows did an update overnight and broke something wth the network comms on Cura. Pretty common occurance however ususally it promts you to “allow permissions” Unfortunitally you have to say yes in order to allow it to work