Ender-3 Max/Sprite/CR Touch PROBLEMS!

Upgraded Ender-3 Max (4.2.2 main board) with Sprite direct head, had leveling issues so added CR Touch. Was trying to setup CR Touch but printer just started printing everything like it was made of sponge, stringy and mushy. Been trying different firmware and then replaced the entire head (head, heat cartridge, thermostat) with a brand new one and same thing. So today I got out a couple temperature probes and what I can tell, when the display says 200°C, the head measures around 150°F. Did the same thing with two different heads. No clue what is going.

As far as the CR Touch, I installed Ender-3 Max - V1.0.1.6 - BLTouch.bin firmware, set the Z offset (-3.25) but when I select Bed Level ON and do a bed level, it runs to the left front corner, Z down then up, then to the middle of the bed, Z down, CR Touch cycles, Z up a little, CR Touch cycles again, then stops. I thought it was supposed to do this nine (9) position level check. But I need to get my temperature situation straight before worrying about that.

Thanks in advance for your assistance.

1 Like

This is what happens when I try to do a level bed. It goes to front left corner, then display says it’s “Probing Point 1/9”, It then runs to the middle of the bed and stops and the display goes back to the main screen. After that I cannot manually jog any axis, the whole system is locked up


Also I tried to do a calibration on the extruder and with the default E-steps/mm set to 93 it barely put out any filament. I had to set E-steps/mm to 400 before it would even come close to moving the amount of filament that I requested. Lots of crazy stuff going on with this printer.

Hello there!

Sorry to hear that you are having these issues! Have you tried to replace the thermistor at all? This would be my first guess to the root of your problems as that is responsible for measuring the temperature of the hotend. Next, you may also consider trying to pid-tune your printer (see attachment below) this tells the printer how much power to give the hotend in order to produce the correct temperature.

As for the bed leveling, that seems a little more complicated. Have you ensured that you are using the most up to date version of the firmware? You may want to try re-flashing the firmware to see if this solves your issues. Also verify that your BL-Touch’s cables are plugged in properly.

Please feel free to get back to me with any additional questions!


I am running Ender-3 Max - V1.0.1.6 - BLTouch.bin and cannot find anything newer. Also, I have a CR Touch not a BL Touch. I cannot find any firmware for the CR Touch but what I read anything for BL Touch should also work. I do not have it wired through the Sprite, I used the provided cable and wired it directly to the main board.

I have replaced the entire hot end and also tried several thermistors. I ordered some new thermistors to try but they have not arrived yet. I also had to set my E-steps/mm to 400 which seems extremely high.

Re: BLTouch, I feel your pain. I have Ender-3 V2 with 4.2.2 motherboard. I installed BLTouch and had similar failure conditions. Once in a rare while it would go through all 16 points and actually print. Fault seemed random. I combed every Internet forum or YouTube video I could find for answers and got a ton of suggestions. I double-checked all my wiring. I tried different firmware versions from Creality. I tried Marlin firmware. I tweaked the adjustment screw on the BLTouch - no improvement. I replaced the BLTouch (I had a spare) - no improvement.

I had my best luck with jyers firmware. I installed 3x3 leveling grid version because it completes faster an I wanted to know quickly if this FW was going to help. It completed leveling every time but print quality was very poor. Layer lines were prominently visible. With a lot more tweaking I could probably have gotten it to work.

Ultimately, I punted. I sunk several weeks effort into trying to get it to work and could never get it to work satisfactorily. I simply couldn’t justify continuing to sink time into it. In the end, manual bed leveling isn’t that big of an issue.

I hope you have better luck than I did.

What did you end up with? Between the heat issues, the feed length issues and the CR Touch issues, I am nearing the point to punt the Ender-3 Max to the curb (or go full Office Space out in the yard). Really frustrating, I think I have spent more time screwing with it debugging than I have spent printing on it. And Creality support has not helped one bit. If anything they confused me even more and I’ve had more help from YouTube but it’s still basically a paperweight.

I used to have an ender 3 max, I too had many problems with bed leveling and the extruder on it (not a sprite however). I totally understand the urge to throw on “Still” and go all office space on it in the yard :wink:

Ultimately I ended up disassembling it and turning it into a voron switchwire. I wouldn’t recommend this option however, it was way too much work and money to be worth it. But there are lots of other parts on the printer that can be used for other projects you may be interested in.

However, if you are still interested in trying to get the printer working I would advise you to try giving a custom firmware a go as chuck mentioned above. You have to be more careful with these customized firmware’s as opposed to a premade one, just ensure that you have properly set all the parameters such as your bed size and probe offset etc. The benefit of writing your own marlin based firmware is that you get control over every setting in the firmware, so it is as customizable as you need it to be. This might be beneficial to you as you have some heavy customizations done to your machine. There are also firmwares such as klipper that you could try but they need an external mcu such as a raspberry pi.

Another thing you could try is going back to the original hotend that came with your printer (I know its not the greatest, sorry). But its just one more variable to eliminate when trying to troubleshoot the bed leveling probe.

As for the estep value, around 400 seems pretty reasonable to me. When I double checked online people seem to get ~400-430 steps/mm for their sprite extruders so yours seems right on the money.

I hope something out of here can help you. Try not to get too frustrated, something has to work eventually right?



I ran it for a while with no BLTouch but had other issues too.

My extruder has “nozzle incontinence”. Filament would be oozing from the extruder when it shouldn’t. That would cause filament “boogers” on the nozzle that would adhere to the model at some point at which point various bad things would happen.

I thought maybe the Bowden tube was responsible so I replaced the entire head unit with direct extruder unit from Creality. Nope, still incontinent. My nozzle needs adult diapers. :smile:

I replaced the brass nozzle. I tried newer brass, stainless steel, and hardened steel. No improvement. I removed the silicon “sock” that covers the print head. No improvement. I tried higher extruder temps. No improvement. I switched to different brand of PLA. No improvement.

Extruder also had issue of occasionally making “clicking” sound. Per Internet chorus, that is caused by printing too fast. I am using factory default print speeds but I slowed-down print speeds. That seems to have helped.

Worse yet, on two occasions the filament got stuck in the print head. I had to completely disassemble hot-end to clear the jam.

I punted again. I am done with this printer. This printer was purchased by my company. I have Prusa MK3S+ unit at home and it is bullet-proof. The automatic bed leveling is perfect and never fails. I have printed PLA, PETG, and TPU with it and they have all printed perfectly. We will probably buy a Pruse XL for work and move on with life.

Sorry I can’t be more positive.

What part of the hotend were the blobs attached to exactly? Did you try making sure all the parts of the hotend were tightened sufficiently?

I replaced the hot end again and appears to be melting filament properly (PLA at 200°C). I ended up ditching all the CR Touch/BL Touch firmwares as they were all flaky and none worked. Would LOVE to find one for Ender-3 MAX with a CR Touch that would actually run around and level the bed. Best I ever got was run to the middle, do the leveling routine and stop, nothing else. Also, when it did this, the Z-axis could not be jogged or moved. I ended up with Ender-3 Max - V1.0.1.8.bin firmware (no CR Touch options) and went back to manually leveling. I also tightened up the drive friction on the Sprite and I had to jump my extruder steps from the default of 93 to 350 to get enough filament extruded to actually print. Retraction of 1mm at 50 works good, too. But would really love to have the CR Touch doing what it’s supposed to.

My ender 3 max had been running for almost a year with BL touch and an orbiter direct drive extruder using firmware from Marlin firmware service nightly build. The Creality firmware was glitchy with the BLtouch. I did find that the BLtouch could get flaky if its wires were run right alongside the hotend and motor wires.

Glad to hear that you have gotten it printing again.

Sorry to hear you had to ditch the CR-Touch, if you feel like trying it again in the future I would agree with @Davethegearhead that you might want to try some custom marlin firmware. I always did my own firmware when I had my e3 max, the ones right from creality were always inferior for me. I can’t speak on how they have improved over time, but given this conversation I would say the improvement seems minimal.

Hopefully you will be able to figure this out in the future, but for now happy printing!

I just got a Micro Swiss direct drive but have not installed it yet. I like the fact the gears are all exposed right out in plain sight. With the Sprite it was all buried up inside and I had not clue what was going on when my filament wouldn’t feed so had to do a complete disassembly just to see what was what. I also bought a BL Touch and hoping that works better than the CR Touch. @Davethegearhead do you have a copy of the firmware you use to share? The Creality stuff was completely useless.

Good to hear from you again!

This sounds like a pretty good plan to me! Myself and many others in the community have had lots of success with the firmware linked below. They have great documentation on their websites, and there are lots of great tutorials on YouTube. The one I linked is just the standard firmware for the e3 max with the 4.2.2 board. But you will be able to add the BL-Touch to the firmware yourself.

I have linked some documentation below, hopefully it will be helpful!