Ender 3 Pro Problem

Wife bought me a Ender 3 Pro to start my interest in this hobby.

Fully assembled thanks to the video from 3D Printing Canada. All checked out but problems with the Auto Home which is not working.

Been told by my local shop that it could be a firmware problems. Current firmware is version 1.0.1.

Any advise or suggestions welcomed and if it is the firmware where do Go for the latest version and how to install. Thank you Robert

@RobertNotBob I am assuming it is new still? Covered by warranty? I would hit tech support. You can get good advise here but tech support can replace parts for free. The tinkering from advise has the potential to void the warranty. Creality need to start making printers that function out of the box better than they do.

1 Like

I second @kitedemon 's caution about the warranty. We’re all glad to help, so we’ll offer some suggestions, but when it comes to anything that involves changing parts (other than nozzles), check with tech support first.

That having been said, you can best get help from us by asking a more detailed question. Just saying “which isnot working” covers a lot of ground. That could mean everything from the print head isn’t moving at all, it’s moving on one, two but not all three axes, the print head is crashing into the build plate, It’s making a grinding noise, the print head or bed are moving in a direction opposite from what you would expect, the gantry only moves up but never down, etc. etc.

Those are just some of the movement-related problems I’ve seen in the last 6 months.

Specifics are always more helpful. Or if you aren’t sure what it should be doing, describe what it does vs. what you were expecting. Photos and / or video is also immensely helpful in some cases where something is difficult to describe.

Before you go messing with the firmware, give us more details. They generally work when straight from the factory although I can think of one item specific to the Ender 5 Pro where they changed a hardware component but didn’t change the firmware to accordingly. I haven’t heard of this with the Ender 3 Pro, however, that doesn’t mean they didn’t do it there too.

So, more details, please, and we’ll guide you accordingly.

1 Like

Thank you for your positive reply, every thing seems to be connected ok and not over tight on the moving axis parts.

So I preheat the nozzle and the bed and when up to temperature hit auto home as required. All showing ok on the home screen up to that stage

Nothing happens during this period except the drive for the filament turning.
There is no movement on any of the axis. Error message shows

Homing Failed:
Please Reset.

Do not have a clue what it means I have not changed any of the settings I have just tried to follow set up instructions 3 times. Does it mean the XYZ Needs to be reset and if so to what. I have to say I am not that tech minded but can follow good instructions. Thank you Robert

Should also mention I will contact the business my wife bought it from tomorrow as they do have obligations under Australian law and more likely to get assistance from them.


The extruder shouldn’t be running while it’s homing. See where you get with the warranty process, that’s you’re best bet.

My guess would be the X axis wiring is marked wrong from the factory, or hooked up wrong on the board.
The X axis usually homes first, then Y, then Z. The extruder shouldn’t do anything while homing.


@MattKX500 beat me to it. That’s what I get for sleeping in :slight_smile:

Yes, you definitely have at least two cables to your stepper motors swapped and one of them is on the extruder.

1 Like

Thank you will have a look after my electician has finished his work and post back, cheers

Thanks Matt checked wires and yes had the wrong ones plugged in, redone them and auto home worked. Just need to level the bed but interruptions, sure it will get done today.

Thank you again for all your suggestions certainly was a warm welcome cheers Robert

Just as a double check as well, check the voltage selector on the power supply and ensure its set appropriately, 120/220 Volt.

Please forgive me for saying this but … Ensure the machine is powered on as well. If you have it plugged in via USB there is enough power via USB in some machines to make the screen light up and even start to heat the nozzle but not much of anything else. I can only say this for sure because I have done it myself.

You get a new machine and want to get it running and forget to change the voltage from 220 to 120.

Almost missed you @MattKX500 , Welcome to the forum, Glad to see you here.