Ender 3 S1 Pro - Nozzle Collides with Infill on Taller Prints

Hello fellow 3D printing enthusiasts,

I’m experiencing a persistent issue with my Ender 3 S1 Pro, which is currently running the latest firmware and utilizes the Creality Sonic Pad as the interface. The printer is stock, with no modifications.

Issue Description: As my prints increase in height, I’m encountering a problem where the nozzle starts dragging across the printed infill. This issue is not pronounced in shorter prints but becomes increasingly problematic with taller prints, leading to prints being knocked off the bed or layer shifting due to the nozzle collisions. It appears as though the Z-step height is slightly insufficient, specifically on infill layers.

Temporary Solutions:

  • Manually reducing the flow rate from 100% to about 85% as the print progresses. This is not ideal.
  • Using 100% infill mitigates the issue but is not a practical solution due to material wastage.

Steps Taken:

  • Multiple calibrations of the e-steps have been performed with consistent results, indicating no need for adjustment.
  • A thorough physical examination of the printer has been done, including belt adjustments, but no mechanical issues were detected.
  • The nozzles have been switched (both are 0.4mm), yet the problem persists.
  • A complete factory reset of the firmware was executed, followed by a re-installation of the Sonic Pad, with no resolution of the issue.
  • Various models and calibration prints from different slicers were tested, leading me to suspect a hardware-related problem.

I seek insights or suggestions on what might be causing this issue and how to resolve it. Could this be related to a Z-axis mechanical component, specific firmware calibration settings, or something else?

I appreciate any advanced advice or insights you may be able to provide.

Thank you in advance for your assistance!

Have you ensured that the z-stepper motor voltage is set correctly in the firmware. The stepper motors may not be receiving enough juice and are moving with a little bit of loss each time. But over time the error may add up and cause this to happen.

It does sound like over extrusion. What slicer are you using ? Something you can try is Z-hop. This should move the head up for travel moves, and stop it from hitting the part.

Hi Matthew, thanks for your suggestion!

I haven’t modified this setting and I did do a full firmware reset as part of the troubleshooting.
Do I find this setting in the Sonic Pad interface somewhere?

I have tried this a bit. The problem seems to get worse as prints get taller but I haven’t really done test prints to figure out if it’s cumulative or something related to extrusion.
I’d really like to figure out the root cause because the printer used to perform pretty flawlessly.

The only thing I can come up with is missing steps on Z. If the issue compounds the higher it gets.

So since it used to work, this would usually point to a mechanical issue in the axis that is affected. In the case Z. So you may have some binding in the Z axis.

So I would go over it. Check for binding, grinding, etc. Could be the lead screws are dry, or the wheels are worn, really you should check for smooth motion on the Z. I would disconnect the steppers/lead screws and see if it is smooth.

I started printings with a Delta. I agree with Mathew it is likely over extrusion issues. (Likely the most obvious first)

Prusa has simple instructions that you can calibrate the flow.

It is called different things in different slicers but it is there.

Coming from a delta, what infill are you using? Some (grid and others) have a higher chance of ‘scrape’ (most deltas have delta scrape)

Try Gyroid.

Thanks everyone for suggestions!

I have really looked over all of the physical things and it really doesn’t seem like there is any binding or damage. I will try some of the suggestions today to see if I can narrow things down.