Ender 3 steppers

Hey guys

I got an Ender 3 for xmas (used, it has a v 1.1.5 board in it) and now
have a problem

There is no movement at all on the stepper motors. the machine heats
fine, but the never energize. They also do not respond to manual control
from the screen.

The display on the screen shows movement in the numbers, as if it were
functioning normally.

Should I be looking at replacing the motherboard, or the power supply ?
It’s got to be one of the 2 and I’d rather not take a 50-50 gamble ! :wink:


There are four stepper motors and 4 stepper motor drivers. Are you saying the X, Y, Z and extruder are all not working?

When you say the machine heats fine, are you saying the bed heats up AND the hot end heats to the point where it will melt filament? If yes to both, that would indicate that the 24V power supply is good.

The fact that you have a display at all and it’s showing numbers means the internal 5V supply is working.

The numbers change because the processor is telling the stepper to move and is counting along as it does so. It has no feedback to indicate that the steppers HAVE moved, so the processor has no idea they haven’t.

I would check that the stepper cables are plugged it at both the stepper end AND at the controller end.

It’s extremely unlikely that all 5 stepper motor drivers have failed simultaneously.

Of course, that’s another possibility, come to think of it… you said it was used. Is it possible the previous owner removed the stepper drivers. On some motherboards, the stepper drivers are separate entities that plug into socket and can be taken out and used in a new machine. Of course, you said it was a Creality 1.1.5 board, so that would negate that possibility as, looking at the photos of the board, I don’t think the controllers are removable.

Can you just confirm for us that all four steppers do not work?

You can also measure the output of the power supply to verify that it is, indeed, supplying 24V. Steppers operate over a fairly wide voltage range. They just won’t have enough torque at low voltages and will overheat (over time) at high voltages, so some variability in the output 24V should still result in a working system.

Exactly. All 4 steppers. Temps are right where they should be, hot end melts plastic and bed makes grilled cheese ;-). Screen indicates its moving but there is no physical movement. I’ve checked all connections are tight and noting is snagged or pulled. It just decided to quit.

The machine ran great for a couple weeks. I got about a dozen nice prints off of it. Few nights ago I started a print and walked away, and wife called me about funny noises. It had a hot end clog and the extruder was clicking so I stopped the print intending to get back to it later. later turned into an alarm going off and the wife shutting off the machine (I never saw the error code that triggered the buzzer). Next morning I turned it on and had this.

I’ve ruled out slicer problems (tried 2 versions of Cura and Prusa) and inspected the boards for burn marks/ anything obvious. I’ve had a Monoprice and Anycubic before this one and been printing for about a year, so not a TOAL noob, I am just more mechanical than electronic/software oriented. There is nothing mechanical wrong with this machine, whatever it is involves either software or electronic hardware. I’ve also tried a few different freshly-formatted cards so its not that.

Check the controller board for a fuse. I’m guessing here, but the fact that all 4 stepper failed at the same time suggests something wrong with the power supply on the controller board. See if there’s a fuse on it and make sure it’s not blown.

OK. So I just learned something. I was trying to find a controller board schematic and one of them showed the stepper motor controller running on a 12V source, so that got me thinking. I’ve always assumed that the steppers were running at 24V on a 24V system, but it suddenly dawned on me that buying NEMA17 stepper we only ever worry about the form factor (dimensions) and never the operating voltage of the stepper itself sooooo after a little digging (very little digging) it would seem that they are in fact designed to operate at 12V. I say very little digging because as far as I am aware the NEMA17 designation describes the physical size of the stepper and the placement and size of the mounting holes and central hole for the shaft, so it’s entirely possible that there may be NEMA17 stepper that operate at other voltages, but I’m starting to doubt this.

If the above is in fact true, it would imply that your controller board has a blown 12V regulator circuit, or fuse attached thereto.


no, no fuse on this control board but that idea led me to find this picture of inside the power supply, and it has a fuse shown at the bottom right of the picture. (component F8A). THAT gives me something to check tomorrow. I know about the main fuse by the switch and that one is fine (or it wouldnt turn on at all)

If that fuse isnt it, then you nailed it with the on-board regulator circuit.

The fuse within the power supply won’t be it, unless the Ender 3 is radically different than most of the other Ender products I’m familiar with. Unless I’m mistaken, the power supply will have inputs for Line, Neutral and Ground, and 3 outputs each for 24Vdc and 0V.

My point is that it is supplying ALL the power to the controller through two wires (vs. separate 24V, 12V, 5V and 3.3V wires). The conversion of the 24V input to the lower voltages is done on the controller board. If you have a display that’s working, then all the lower voltages needed for it are being converted from the 24Vdc input so your 24V is (roughly) OK. Check it if you want to, of course, but my money’s on a defective 12V regulator circuit on the controller board.