Ender 3 V2 no longer returning / cooling down after job

Hey group - brand new here. Hope everyone is happily creating!

I’ve been running an Ender 3 Pro for about a 1.5 years w/ stock parts and no issues to date.

I print using the stock nozzle and run the machine 1-2x per month using PLA to make the odd part needed in my shop for jig knobs or guitar parts I can’t find.

All has worked great but recently the machine hasn’t been cooling down / returning to the front position after a job. My most recent (additional) issue was stringing, so I went down the Google rabbit-hole and started finding articles on the filament gap in the Ender 3 Pro nozzle. This prompted me to check and in addition to the nozzle being caked, the top of the Bowden tube.

I removed the tube, used some tube cutters to trim off the plugged end and then added the spare nozzle that came with the initial Ender kit - this solved the stringing issue but not the cool-down / sans-return issue mentioned.

Any insight in this regard is appreciated. As a note, I’ve re-printed older files just to troubleshoot to ensure this wasn’t a setting issue with the most recent Cura update. Older files that worked previously are still showing the same issue; job finishes, nozzle kind of rests on the part, temp stays up and bed doesn’t return to the front.

Additionally, I figure I should stock up on some nozzles as I’m onto my last stock one that came w/ the machine.

In addition to spare nozzles, what would you recommend as a good, basic upgrade kit for what I’m doing? Are the stainless nozzles overkill for the standard PLA filament I’m using? I figure I’d pick up a half dozen nozzles to keep on hand and then noticed the Capricorn tubing… just looking for some maintenance parts and upgrades while I’m in under the hood.

I’m just printing the parts to do the ‘Bowden Gap Mod’ from Thingiverse that you’re all likely familiar with.


In cura, make sure your end g-code looks like this.

G91 ;Relative positioning

G1 E-2 F2700 ;Retract a bit

G1 E-2 Z0.2 F2400 ;Retract and raise Z

G1 X5 Y5 F3000 ;Wipe out

G1 Z10 ;Raise Z more

G90 ;Absolute positioning

G1 X0 Y{machine_depth} ;Present print

M106 S0 ;Turn-off fan

M104 S0 ;Turn-off hotend

M140 S0 ;Turn-off bed

M84 X Y E ;Disable all steppers but Z

1 Like

hi @mwhitney

Welcome to the Forum, Glad you found us here in our little corner of the internet, Pull up a chair, I got a mars bar here somewhere, Help yourself.

as @Bikemike mentioned usually it’s an issue with the end Gcode, Sometimes they get corrupted and just don’t run properly, Usually deleting and recreating the profile is enough to kick start it going again. Keep us up to date and make sure you get it running right again

1 Like


  1. Jyers UI firmware upgrade-free

  2. Get a bed spring, capricorn tube and Creality metal extruder kit. - cheap

  3. AN ABL like the BL/CR Touch, makes first layer and bed levelling when used with the JYers UI a snap. Not free but definitely worth the money.

  4. At some point a dual Z axis upgrade is a really nice feature. Not a priority unless you are going to dump the boden tube for a direct drive then you will need it.

Spare parts - Nozzles, wheels, belts, thermistors, heater cartridges to start. All these parts will fail eventually, it may take a while if you don’t print much but consider them consumables.

There are many free printable downloads on Thiniverse that are upgrades for the Ender series printers. Roller filament spool holder, filament guides etc, etc, etc. to name a few. There really is no end to what you can upgrade on an Ender and turn it into the eqivalent of a much more expensive printer for a fraction of the cost, which can be spread out over time. That is one of it’s biggest strengths.

1 Like

Hi Mike -
Thanks for your quick reply. For the code you mention above, is this something I add in Cura somewhere that will then append to each file?

Something that I’m not understanding is that older files that previously worked are producing the same result at the end of the print.


Thanks for the welcome, Jason.
Just seeking clarification on where that end g-code is added (to each individual file, or somewhere in Cura). I opened the file in question in notepad and didn’t see the code listed by @Bikemike. I’m new to this side of things - to date, I’ve just modelled, exported as an stl, brought into Cura, sliced and saved.

Thanks again.

Thanks @Loosenut - ‘Googling’ as we speak!

Open Cura and at the top left you will see the printer you have set up, click on that and click manage printers.
In the next window on the right, click Machine Settings.
The End G-code is on the bottom right.

1 Like

Thanks Mike - got it.
I’ll run a test print and see how it goes / report back.

(EDIT) — I just opened up the Cura settings and that code was there, verbatim. —

Still not sure what the issue is.

Maybe load up a small part, slice and save the file. Then open in notepad and check to see if the end g-code is there. It will not be at the very end, it will be above the ;setting comments at he end.

other option is to see if the firmware has gone bad. Connect to the printer with a USB cable and pronterface and individually enter the lines and see if its throwing an error message back at you?

Are you using factory firmware or something from another source?


Hey gents -
Finally had a chance to get to this again…

@Bikemike I’ve just sliced another file and did a ‘control F’ in the gCode and found this bit:

G1 E-2 Z0.2 F2400 ;Retract and raise Z
G1 X5 Y5 F3000 ;Wipe out
G1 Z10 ;Raise Z more
G90 ;Absolute positioning

G1 X0 Y220 ;Present print
M106 S0 ;Turn-off fan
M104 S0 ;Turn-off hotend
M140 S0 ;Turn-off bed

M84 X Y E ;Disable all steppers but Z

Looks like those commands are there.

@Jason I’m just running the factory firmware with no mods at all. I just started a new print and will report back here once complete.

Thanks guys.

I ran a new print last night and made no changes at all. At about the 99% timestamp I began recording the print to upload here and it performed perfectly.

I suppose the threat of public humiliation coerced the machine into compliance ;). Next time things act up, I’ll just pull out the camera.

So far, I’ve printed 4 knobs using the same file and all have worked, machine cools off, bed moves forward etc… strange.

Thanks for all the feedback. Hopefully things keep working as per.

1 Like

thanks for the update @mwhitney appreciate it.

Sometimes the gremlins move from our head to our printer and back again. :slight_smile:

1 Like

Ha! Thanks @Jason :slight_smile:

I spoke too soon.
Last night while printing a final knob (same file as the preceding three others from the day, all of which printed perfectly), I looked over to see the print head dragging the part around. Plastic was melted all around the nozzle. Nozzle and bed temps confirmed / same as previous prints (200 on the nozzle, 60 on the nozzle).

I dismantled and removed the melted plastic / detached the brass nozzle and checked again for the plastic between the tube and the nozzle but all was clear (I had to clear that last weekend and trim / reinsert the tube). I’ve yet to do the Thingiverse mod for the ‘tube gap’.

Back to my point: I powered down and ran the job again this morning. Now it appears that the nozzle is dragging along the bed as evidenced in the video by the scorch marks showing the knob pattern on the bed (this is new / bed had no marks on it until last night). I can push filament through the nozzle, manually, but no plastic appears to be laid down when the job is running.

Any insight here is greatly appreciated. The machine ran flawlessly for a year and now it’s proving temperamental. No doubt, it’s in need of some maintenance - just not sure where to look at this point (or what to update / upgrade).

Here is a link to a video: https://drive.google.com/file/d/1ds6A1AikU5Qp02Btjy_TFezxtVjNRHxE/view?usp=sharing

Thanks again.

your Zoffset has deff shifted, Maybe is the Limit switch loose or moved?

If you relevel the bed with paper off the knobs you should be able to eliminate the new problem. with the nozzle touching the bed it simply won’t extrude so don’t worry about that right now so much until you get the levelling redone.

How big are these knobs? I have had parts dragged off of the bed because they where small and I had the print speed set to high. The solution for me was to cut the print speed from 50mm to 20mm for those parts. I have also printed very small parts at speeds as low as 10mm/sec so as to not pull them off the bed. If levelling the bed doesn’t help maybe this will.

@Jason - thanks for that. I followed a TY video on re-zeroing (haven’t done it since I bought the machine) and that resolved the issues. Probably good practice to do this every few months I’m guessing or after ‘x’ number of prints… took all of 5 minutes. The knobs are printing fine now.

That said…

@Loosenut - thanks for your insight. They’re just knobs for jigs and such in my shop, so maybe 1" to 1.5" across. I account for a hex nut to be recessed into the stem in a vice (typically for a 1/4" or 5/16" bolt). I’ll keep your points in mind for any future issues that may seem to be related to size. I had printed a good dozen of these prior, so I felt confident it was some other issue. The rogue nozzle and zero-ing issues seem to be the culprits… hopefully it’s smooth sailing now. I’ve printed two more since the adjustments.

On a side note, any particular nozzles you guys recommend? Same brass ones?


.4 mm is the standard, change to bigger nozzle for bigger prints smaller for smaller etc.
Brass is good enough for standard PLA, PETG etc. You don’t need the more expensive hardened ones unless you are printing an abrasive or other high wear material. Be advised that all Brass nozzles are not alike, there are good one and bad ones for about the same price. Machining quality counts.

Thanks @Loosenut. Would you recommend the .4mm brass nozzles supplied here or would you be looking at another vendor? To date, I’ve been fine with PLA but don’t have a basis of comparison. I’m using up PLA from this vendor on Amazon:


So far, I think* it’s been fine. I’ve been able to also make a few custom guitar parts, i.e. trim rings for pickups on vintage gear and was able to sand out the machine marks / layering with 180, 220, 320, 400, 600, 800 and then polish on a buffing wheel to achieve great high-gloss and ‘factory’ results.

Would you mind sharing some sources for nozzles, PLA and perhaps suggested applications for PETG etc. over PLA (I realize these are likely ‘101’ questions - just haven’t ventured beyond PLA and stock nozzles).

Also, do you own the same machine? I’m curious what the first-hand experience is regarding the Thingiverse mod to correct the Bowden tube issue.

Thanks in advance!