Ender 3v2 shutting down? Mid print

I have an issue with my Ender 3v2.


When printing the print will fail at random times during the print and leave a blob. I am printing from octoprint and the serial log just says that there has been a disconnect and no response from the printer. I check the printer and it’s still on, both bed and extruded are STILL HOT and extruder head stuck in last printing spot.

I was also getting some massive layer shifts, but I seemed to have solved that problem with a new lead screw and tightened coupler, stepper mounts. Seems the layer shifts were probably unrelated. When they layer shifts were happening I was getting random little shocks, like static shocks when you rub your feet on the carpet.

This is with multiple different files, not the same one. Sometimes it will fail early at say 45 mins, or sometimes 2-3 hours in.


  • Ender 3v2 (1yr 1month old, from 3DPC)
  • microswiss hot end with direct drive
  • motherboard 4.2.2 (since replaced with 4.2.7 as part of troubleshooting problem)
  • power supply LRS 350-24 (replaced as part of troubleshooting)
  • bltouch added after problem started
  • OctoPi on a pi4 16gb, usb cable with 5v tape blocked

Troubleshooting steps

  • at first I suspected octopi, so I updated to latest, no joy
  • usb cable, changed and 5v taped, no joy
  • tried printing from SD card, no octopi connected, no joy
  • updated to latest marlin, no joy
  • replaced 4.2.2 board with 4.2.7, no joy
  • printing from a dedicated power source, straight to wall, nothing else connected, straight to breaker panel, no joy
  • replaced power supply with another MEAN WELL LRS-350-24, no bloody joy

EDIT: Right now I’m trying a new power cable. FAILED AGAIN 1h 15m

If that fails, I’m all out of hair to pull out. Any suggestions? I’ve tried crying myself to sleep, no joy.

At least I’ll use the replaced parts to upgrade an old Ender 3……

I’ve had the same problems with Octoprint and Pronterface.

Sorry, but I’ve never found a solution and always print from the SD Card/USB Thumb Drive. It seems like the connection gets lost but I’ve never been able to track down where the problem lies.

Hi Dune
Welcome to the forum - glad you found us!

I spoke to PJ in our tech department and he suggested to double check the USB cable that you are using. Cable must transmit data only and no power. This could cause the issue that you are having with your prints.