Ender 5 pro blank screen

Hey guys I had a mess on my hotend, filament didn’t stick to the bed, as I was cleaning it off, my screen went to a blank blue.

When I turn the printer off and on agian, the bltouch starts as normal, the fans all run but the screen stays blank,
I tried putting some firmware on the card and turning it on to re up the firmware but that did nothing.

Any ideas? Only bought the printer in Dec.

Update, so the printer won’t connect to octoprint either, seems like it’s timing out.
So. Yay.

Really hoping the printer isn’t bricked. That would piss me right off

I wish I had something to help you out there.

Though on the octoprint it says baudrate, then the next line is 57600, is that correct/normal for your machine?

Also, youve double checked the connections. Id try replugging the lcd and your octopi to the printer board just in case they wiggled in a weird way somehow.

The baudrate starts high and falls with every failed handshake with the printer

And yes I checked connections

Hmmm :s im not sure what to make of that. Ill see if i can come up with any ideas that either restore capability or confirm its bricked.

Turn the printer off. Connect a USB cable to a computer and check the LCD screen. On mine, it’s dim, but the display can be seen to be going though the logo sequence to the information screen. Obviously nothing else will work, but you’d be supplying the minimum power needed to get the controller’s CPU running and sending data to the display. As I say, it’s barely readable but I just tested it and it works on my 5Pro

Usually the octopi does the same thing, (with a little flickering) this time it doesn’t. I’m thinking I may wind up having to replace the main board

The “blue screen of death” is a known problem usually fixed by reflashing the firmware. But not this time apparently

HI Benchy

Usually when the screen is just blue its the connector in the wrong port on the back of the screen or in upside down. I know you have worked a bit with these printers so I am kind of eliminating that one.

I am not sure if you may have access to a different screen or machine. If you have an ender 3 (or if your neighbor might?) I would try to take the screen off your machine and try it on there. if you can confirm the screen is working see if you can connect with pronterface and move axis or heat extruder.

I hope this may give you an idea to check and hopefully not a bricked board.

Before you go replacing anything, unplug the hot end. There’s a possibility that you may have shorted the heating element wires, either to each other, or to the heater block (and hence, the frame). This is especially likely if you used a brass (or other wire) brush to clean the hot end. All it takes is one stray wire bristle.

If unplugging the hot end doesn’t work, before you go replacing anything, and since you’d have to have the controller case open anyway, unplug everything except the DC power and screen from the controller board and re-test.

If that doesn’t work, we start clutching at straws: unplug the display from the controller and try communicating with the controller via the USB port using a terminal on a computer, just to acknowledge that it’s sending/receiving characters. If that fails, it’s definitely the controller board.

1 Like

If the hot end was shorted, what would be the fix? Replace the hot end?

assuming the board is undamaged as a result simply replacing the hot end cartridge is usually all that is required.

You can’t damage the hot end itself by shorting it out (but you can damage the controller). If you think the hot end is shorted, inspect the heating element very closely for a tiny piece of wire that may have detached from a wire brush. It may be necessary to take the heating element out to inspect it.

Alternatively, bare wire from the heating element may have been bent while you were cleaning the gunk. The bare wire could be contacting the heat block thereby possibly shorting to the frame, or one wire could have contacted the other.

Ideally, the heating element’s wires should be insulated all the way up to the heating element, but that insulation may have shifted during cleaning, exposing the bare wire which could short against each other, the aluminum heat block, or a wire brush bristle. Those are the things you’re looking for.

I take it you’re asking about this because you’ve unplugged the hot end and the display came back to life?

No I’m at work right now, but as I was cleaning the hotend at the time (with a brass rifle bore cleaning brush actually, something I will no longer be doing going forward) it seems like a very plausible answer to my issue, and since I can’t really follow any leads physically I may as well pursue with questions.

I know I can’t actually short the end itself, but the cartridge or the frame ground itself could get screwed up.

When I checked the printer after I couldn’t find any burn or scorch marks even on the boards, and the fuses were still intact.

So with everything disconnected, except the servos and screen, and connected to the pc via USB, pronterface hangs on connecting and can’t successfully access the controller board.

I’m beginning to think I’m screwed may wind up just bringing it to the store for repairs. I have too much on the go

Well, the one last thing to check is that you’re still getting 24V from the power supply. If you don’t when the controller is plugged in, do you get 24V when the controller is disconnected?

There are other things I would check, but that gets down to nitty-gritty board-level repairs. If you haven’t got the time or the survace-mount soldering equipment, you’re probably looking at a good excuse to upgrade the controller board.

I am just going to add a question.

There comes a point where you may need to cut your losses. How much time energy and frustration has been poured into this printer? How much money is committed and how much more time and money will it take?

You are the only person that can answer this, but it is something to consider, sell this printer and parts for what you can and invest the cost of new parts in a better printer with brand name parts, that is known reliability so you can just get on with printing.

At some point the printer is a hobby or printing is.

I was given this same advice a couple of years ago and I purchased a prusa, it has been completely reliable and almost never has an issue.

Something to consider for your self, are you throwing good money after bad?

Most of my expenses have been upgrades, and this will be the first part I will have to actually replace because it was needed, and to be perfectly honest, it’s probably my fault.

I can appreciate the cut your loss mindset, however I bought this printer specifically to learn. The down side is that right at this moment, I don’t have time as we are getting geared up for our wedding, and the printer was going to be printing some little Decorations for the event.

Honestly a board looks to be about 70$ a screen another 50$ and a heat cartridge looks about 7$
I may just replace all of it and be done with it. To a gun guy (who buys a box of ammo for 30$ and literally burns it lol) these costs aren’t that bad

I bought the creality so I could screw it up, and not cry too loudly.


I bought a new control board, a new touch screen, a new thermistor and heat cartridge, lol. Actually not a bad price, less then 10 boxes of 12ga target load lol.

Now I think it’s just finding the right firmware for an ender5 pro, with a 4.2.7 board, a touch screen and a bltouch. LOL

Any help on that would be appreciated,
I tried with the following file

Marlin2.0.1 BLtouch V1.3.1with-adapter board firmware TMC2225(temporary).bin

And the screen showed the creality logo and a bar but went no further…