Ender 5 Pro X-axis stuck


I have not been able to use my ender 5 Pro for sometime because I have yet been able to figure out what is wrong with it. My x-axis seems to be sticking. As in it can’t even be moved by hand sometimes.

I have removed the belt and checked

  • The driven turning piece moves freely
  • I can move the extruder when the belt is not on freely and it slides and moves normally
  • Without a load on the belt driver it can move by hand, and when run with the printer on it spins fine

The belt has some fraying where it seems to have been rubbing.

Not sure what to do as I cannot use my printer anymore.

What are the chances the pulley isnt aligned. Its hard to explain in text (for me anyway) but is the fraying happening on one side or both sides of the belt? You may need to move your pully (if possible, i dont have a ender 5 for my reference) in a way to better align it to the belt.

This is what i mean in theory (step 29 of y and z axis assebly

I know its no ender 5, but the point is the same.

Send pictures.

If the belt is fraying, replace it.

When you refer to “extruder” I presume you mean the hot-end. “Extruder” usually refers to the red thing that is the first thing you feed the filament into from the reel; it has a stepper motor attached and is the entry point to the Bowden tube.

I assume you mean: without the belt? That the stepper motor is turning fine is good. That means the motor hasn’t seized.

My guess is the other end of the gantry is where the problem lies.

Here’s what mine looks like:

It’s fortunate that you brought this up as it made me take a close look at my pulley and belt. When I first set it up in November, I was careful to align that belt dead-center on the pully so the belt wouldn’t rub on the aluminum. As you can see from the photos, my belt is now rubbing on the frame. That’s going to lead to my belt fraying and catching on the edges of the aluminum. I’m glad I caught it in time. Anyway, if yours looks like mine, or worse, you need to adjust that pulley on the end of the gantry. As I say, send photos for clarity, but I suspect that’s where your problem lies.

Hey, so you would think I would use technical terms for everything but I am still fairly new at 3d printing. So I have tried moving my belt but it always ends up sliding back to its position at the top. On the drive unit. When I was saying the extruder I was referring to Nozzle assembly.

My X stepper works fine but the v-belt keeps riding up. I don’t know if this is causing my issue. I included pictures this time. So if my belt looks like it is turning thats because it sort of does when the Nozzle assembly moves towards the one end.

1 Like

Hey, so the belt is actually wearing on the bottom side only, the top side shows no signs for fraying or threads coming off the belt

1 Like

It’s odd that the belt is fraying on the bottom. Looking at where the teeth are impacting the aluminum frame, I would have though that would be where the damage is being done.

At any rate, adjusting the belt is quite simple. On the right you see the two brass anchors for the belt on either side of the Nozzle Assembly. The belt sits in an “L” shaped slot that is significantly larger than it needs to be. The reason for that is it gives room for adjusting the height of the belt. Move the brass anchors up and down in the slot to adjust how high the belt rides.

Well my friend its still not the smoothest however, it can move now in the x-axis using the steeper. I really appreciate your help in teaching me how to adjust my belt. I tweaked my Y-axis while i was at it

1 Like

Good to hear it. I’d still replace the belt. Oddly, I can’t find it on 3DPC’s web site.

1 Like

Actually you know what. I just tried printing and I think my motor is seized ahaha. So 15 bucks for a new motor

Disconnect the belt and use the movement controls on the control panel to move the X-axis without any load. Does it move? You indicated in your first post that it moved freely by hand. If that’s the case and it’s “stuck” when powered (without a load), you may either have a wiring problem or a problem with the controller. There are four wires that power a stepper motor. They must be pulsed in a specific sequence. If even one of the wires is broken or has a corroded terminal (or the terminal has come loose - is it snug and all the way in?) then the stepper will appear to be “stuck”. It will vibrate in place yet turn freely by hand.

The simple test is to connect the extruder (the place where the filament enters the system) motor cable to the X-axis motor, then try to move the extruder motor via the control panel. As you do so, the X-axis should move. If it does, the motor is fine and your wiring has a problem.

In that case, thoroughly check the X-Axis motor cable starting at the motor and all the way back to the controller (you’ll have to open the case). The connectors at both ends should be tight and level (not inserted at a slight angle) and the cable should be undamaged.

For what it’s worth, I had a problem with my X-Axis a few months ago. The cable had gotten snagged on the extruder wheel and had been pulled out of the socket. The X-Axis cable also contains the X-Axis limit switch and because of that the cable didn’t simply drop out, which would have made it obvious. It was hanging from the limit switch. I’ve since been more careful about how I route my cables.

Since you have the same printer, it’s obviously possible this has happened to you too.


So I had previously had everything running by hand and by using the control built into the printer. The belt is not binding anymore but after trying to print, the print was fine and at a certain point it got stuck. I cannot move the x-axis by hand or using the control. I have encountered this before and to overcome it I need to take the belt off which will allow me to move the x-axis freely.

For this reason I don’t feel its the power cable because with the printer off and with the printer on with the x/y stepper disabled I still cannot move in the x-axis. So for 15 bucks it seems like not a bad thing to try. Like its like a break is on.

Are your wheels tensioned waaaay to tight? Also check for points of impact. All the pictures in this thread show lots of wear and marks on the belts and wheels, that my printer just doesn’t have.

Also are you able to remove the belt tension, and have the stepper run on its own? I’m not sure if these steppers are the adjustable kind or not. But if they are you can adjust them with a small bladed screw driver, I’ll check later when I’m near the printer

Hey Benchy,

So I do not believe the wheels are tensioned too tight as they move very easily along the track when the belt is not on the X-axis stepper. Yes my belt does have wear and that has been adjusted thanks to LegoManiac.

When I have removed the belt the stepper does run on its own but tbh I usually give it some manual play before I run it using power. After thinking back on it I do believe that sometimes the steeper is a bit hard to turn manually at first which is further supporting my theory that maybe I just need to swap the motor.