Ender 6 setup with Bl Touch

So just assembled the Ender 6 with Bl Touch.
Two questions:
How do I update the firmware and what slicer should I use to take full advantage of the speed this machine promises.
Cura 4.9 and no profile!?!

You know why it’s called the “bleeding edge”, right?

You’re on that edge with a printer that’s only been on the market a few weeks. You now have to wait for the rest of the world to catch up, or be prepared to blaze the trail yourself.

Get the updated firmware from Creality’s web site:

I find it odd, though, that they don’t seem to have Ender 6 firmware at all. Usually the shipping firmware is available, even if there isn’t anything newer.

Once you get the firmware, you put the file that has a .bin extension on an SD card, turn the printer off, insert the card, and turn the printer on again. It will load and install the new firmware.

As for slicers, any slicer will do. Cura is the one I use. Visit CHEP’s web site to download his latest Cura profiles at

That icon has nothing to do with the web site’s profiles.

I don’t see an Ender 6 profile there either, so, since the printer is most similar to an Ender 5, download an Ender 5 profile and adjust the settings (build volume, accelleration, speed, e-steps) accordingly. Don’t forget to save your profile periodically as you go along.

Teaching Tech’s calibration web site is almost required reading for any 3D printer owner. Read every page of it starting with the tab at the top-left and working your way right. It will help you get your printer tuned. If you aren’t sure of a value (like maximum speed), start conservatively and work your way up. This whole process can take a few days of; print a test piece - evaluate it - tweak settings accordingly.

https://teachingtechyt.github.io/index.html

1 Like

Prusaslicer has the 5 with the BL touch. They usually run faster print settings than other slicers so I would guess it would be a decent starting point. I run my artillery at 120 mm/s by times. I will be interested it how much modding it takes to deliver the speed they say run.

1 Like

Fun fact: When I hit the info icon on the machine, it tells me the version number is 1.0.4.9
Naturally, that is the version of firmware I tried to install 11 times.
Nothing but the opening screen. No amount of booping the screen would change it. Card in, card out. Different card in…nothing.
On the 12th shot, out of pure desperation, accompanied with unadulterated terror of mucking up my machine, I installed version 1.0.2.
Now things seem to working. The Auto Leveling icon has appeared and the Bl is lit up.
Did I miss something or is the manufacturer pranking me.

When I went to Crealitiy’s download page (linked above), I didn’t see anything for the Ender 6. I figured that was odd, as stated, passed it off as being because the machine was too new and they hadn’t got around to updating the page. Where did you get the firmware?

Creality.com/download.

But I should say, the Z Offset isn’t sticking, the filament detector is glitching like crazy and nothing is working.
This thing is probably going back.

1 Like

You know, I buy local from actual people with the expectation they’ve got this kind of thing covered.
I didn’t build this from a kit some kid programmed in his mom’s basement.
I’ve spent less on used cars and was hoping to avoid these startup issues.
The BiquB1 had none of this malarkey; I’ll tell you that for free. And that was my first printer.
Shouldn’t this get easier?

Right now, I’m looping the filament around a windex bottle to get the sensor to read. This is not sexy.

thanks for posting the screenshot. I hadn’t realised that all this time the link I had bookmarked was to the creality online store’s download page. I’ve been wondering why I haven’t seen any firmware updates in a while.

I’m not sure what to tell you about the filament detector. They should have some sort of adjustment. The ones I’ve seen are basically limit switches in a housing that directs the filament across the switch, but sometimes the switch activation lever needs to be bent slightly.

I am very sorry you are having this experience. I hope that you have contacted tech support and expressed your displeasure with the product and that they are in the process of resolving the issue. It is all I can do not to rant about my terrible experience. In a nut shell bought a new printer (my fourth since 2016) and spent 3 months and doubled the cost in parts I needed to replace. I have a new rule, if it is full of copied parts, and ripped off designs. I am not going to buy it. I want a printer I can assemble (partly or fully) calibrate and not touch again for years. My Prusa and mono price did that, no mods no messing with the printer instead of printing.

I’ll call. But I’ve got to psych myself up to get my face ripped off by that evil ‘music’ they punish callers with.

1 Like

Yes I heard that. I hate calling but at the same time it is important to let the companies know selling poorly assembled products is not acceptable.

Stubborn as I am, I have found some solutions without resorting to calling in.

  1. use the wrong firmware! Why not.
  2. disable the z stop! Dangerous? Hell yeah. Is my new glass bed scratched? You betcha.
    Would it work any other way? Nope.
  3. unplug the filament runout detector. Apparently, a properly calibrated limit switch in a box is a bridge too far for an 800 dollar rig.
  4. will the machine remember anything I’ve done next time I turn it on? Let’s start a pool.
    Running my first print now…further updates as events warrant.

Ted sadly that all sounds like a similar story. I am quite fed up with there string of companies (all named with same convention, city name, company name technology company limited.) That are using cloned parts have poor assembly quality control, poor documentation and poor to zero after sale support. The printing community really needs to put the foot down and say no this is not good enough.

1 Like

So a print has been done. A lot of it was just the normal calibration, but no, the machine does not always remember what it’s doing. Sometimes it does, sometimes it doesn’t.
This maybe wouldn’t be worth complaining about if the firmware did not insist on running BL Touch for every print.
It’s exhausting just waiting for the thing to start.

Also, I know this forum is closely monitored by the 3d Printing Canada staff and I haven’t heard a word from them.
I may not be their best customer, but I’ve dropped over 2k in the last 7 months in that store.
It baffles me that they aren’t more interested in the problems that come with this printer.
If only to shut me up on the internet.

It must be tough for them. I can see how difficult it must be to sell high end gear that is far more reliable but out of the price range and the poorly assembled ones copied and cloned. My artillery x1 (Shenzhen Yuntuchuangzhi Technology Co., Ltd. related to Shenzhen Creality 3D Technology Co., Ltd seems likely) Needed almost every part adjusted changed or repaired. I didn’t replace either board, and 2 steppers and the metal skirt. The rest needed work. I had one of the secondary boards with a gap under the connectors, Dupot connectors in JSTXH sockets held in with hot melt glue.

I don’t know how a manufacturer allows that to leave a factory.

What can a reseller do? Not much. They can’t repair every printer voiding the warranty, they can’t make the manufacture change, if all the printers have issues forever returning defective ones is not going to work. No solution. I recommend everyone with an issue email or call the support people only the manufacturer will change when the community stops fixing new printer issues them selves and makes the manufacturer do it.When it is more expensive to deal with repairing the result of quality control issues than correct the QC issues it will change.

I got three boxes of parts from Artillery eventually, belts gears extruder bed stepper… I had already bought most of that myself but the manufacturer did eventually send replacements.

A few days ago I mentioned CHEP’s profiles. Well, he released new ones today for Cura 4.10

1 Like

Weird yet great news!
I got some firmware from the forums.creality website that looks and smells exactly the same, but worked.

The run-out sensor issue has still not been resolved, and I don’t know if/how to save a BlTouch mesh so I don’t have to run it every print, but plastic is getting squished into place.
Happy day.