Extreme Layer shifting issues

I purchased CR-10S Pro V2 off of 3D Printing Canada and I have been using for just under a year.

It’s been running fine but I started having serious problems with layer shifting

I believe it is related to the Y Axis band as the shifting problem is in that direction.

The front of the print moves progressively closer to towards the rear of the printer with each layer

I’m not sure what the problem is or how to fix this. I have tried shutting off and restarting. I have also tried reformatting a new SD card just in case it was the file or the card that was the issue.

If anyone has any suggestions on how to fix the problem I’d love to hear your feedback


double-check the little pulley that drives the belt and see if it’s tightened properly. this issue seems mechanical to me

Thanks for the reply. I did check the belt tension…seems fine…I tried manually pulling it to see if moved the print bed and it seemed to work without any noticeable issues

I’m still contemplating this, but in the mean time, check that the grub screws that attach the belt pulley to the stepper motor (Y axis) are tight. Usually, if they start to get loose they’ll slip. The slippage is most pronounced on rectangular objects where the bed has to go from being stationary to full speed very quickly. You won’t, for, example, see much of it when printing a cylinder since the acceleration of the bed changes gradually. I would, however, expect to see the same slippage when transitioning from stationary to full speed in the opposite direction.

The behaviour is very much that of a binding cable. Is the bed heater cable clear?

Also, I really want to blame the cat.

1 Like

yes, but the connection between the motor and the belt can not be allowed to slip. if the pulley is slipping on the motor shaft it could lose it’s place

I think that might have been it - You are talking about the two hex screws at the base of the spindle which attached to the stepper motor right ? Well even if you weren’t referring to that, I think that might be it as they appeared to be lose.

That was what I’m referring to. They’re called “grub” screws or “set” screws. If they’ve worked loose, check the other screws on the other steppers too.

Well, first test went great, I think that did the trick

Thanks for the help, cheers