First layer issues driving me mental

Thanks for all the suggestions folks!

I’m still troubleshooting on this one. My latest hypothesis is that for whatever reason the ABL mesh is not being used. I level the bed, set z offset, and then run the bed leveling probe to generate the mesh. In octoprint the mesh looks pretty decent - definitely within the bounds where ABL should be able to adjust for any variability. And yet it seems to not be using it at all when printing. I’m completely confused.

I had originally just had g28, g29 in my start code which didn’t seem to work. I added an m500 and then m420 S1 Z2 after those, which in theory shouldn’t be needed but I figured I’d try. Same result. Is there anything else that might be missing? Is there a way to definitively test if the printer is using the mesh as it prints?

Hi everyone!

It’s been a little while but I wanted to update this thread and reveal my solution. Ultimately it took me sitting there and really watching what the printer was actually doing to figure out what the problem was. It turned out that my placement of the filament runout sensor at the top gantry was the culprit. Because the feed hole from the filament storage cabinet above the build chamber in my enclosure was not centred directly above the runout sensor assembly it was adding drag to the filament at that point. Then, even though I had added a bearing so that the sensor assembly would swivel as the extruder assembly moved it was causing another drag point on the extruder. The net result was that when the extruder assembly would move all the way to the left or right sides the filament itself would pull in the opposite direction so that the nozzle was no longer parallel to the bed and the z offset was higher than it thought it was, which caused some prints to work beautifully if they were directly in the centre of the bed but as you got further away from centre the prints got progressively worse.

So to remedy this I’ve removed the filament sensor from the top gantry and put it right on top of the extruder stepper feeding into the direct drive. Now the filament goes straight down from the upper chamber into the runout sensor so there are no bind points to cause the issue. Once I made this change my prints started coming out beautifully.

Thanks all for all your suggestions!!

1 Like

that’s awsome spacemoose, thanks for letting us know, Glad to hear you got it all worked out.


Could you post some pictures of your set up? I’m curious as to how there could be so much tension on the hot end that it would twist.

Hmmm I’ll have to see if I had any pics of before I made the change. I’ll check. Basically imagine that the filament was being pinched at 2 different points at the max range of motion… it was just enough that it was tilting the hot end slightly - JUST enough that it was causing problems. Incidentally prints since then have been near flawless so it was definitely the problem.

1 Like

great you figured it out… went through an cycle of leveling on my end recently too. This may be specific to my case and likely flaw in the firmware. I noticed my mesh was being updated every time I set a z offset. The mesh is only corrected after rerunning the ABL again.