Homing all, X keeps running

Hey everyone, yesterday I got myself a Duet 2 board to do a reprap conversion on a printer that I got. after rewiring all of the stepper JST’s and making a custom breakout board for my endstop switches, I ran some tests to make sure my wiring was correct. everything works as it should, dual Y’s don’t fight each other, X moves as it should and so does Z, and all of the endstop lights come on when the corresponding switch is pushed.

Homing each axis individually works fine, no issues there, but when I home all, X will keep running and stalling until the other axis endstop triggers are pushed.
Is this a Config issue or a wiring issue? I noticed when I plugged in my X motor I got a warning about “Motor Phase B may be disconnected”, but the stepper appears to run fine. Also when the X motor is plugged in the endstop lights are very dim as opposed to off, possible backfeeding?

Any guidance would be apreciated!


So I’ve noticed when homing X or Y independently, both X and Y move at the same time, both motor harnesses are completely isolated, is this a config issue?

I’m a bit confused. You didn’t specify what the base model of the printer is, so can I assume it’s a gantry-type (Ender3, etc. etc.)?

You said it had “dual Y’s”. I’ve never heard of that.

Dual Z on a gantry printer is common so that both sides of the gantry get raised and lowered at the same time and the gantry is less likely to move the left side up and down more than the right. This is usually solved by putting lead screws on both sides of the gantry and either connecting them with a toothed belt or driving them with independent stepper motors. Those stepper motors, in turn, need to be triggered simultaneously and so motherboards will have dual Z-axis ports that are really one port (from the controller) driven by two stepper motor drivers. If you plugged your X and Y into these ports by mistake, you would get both X and Y moving in sync.

For diagnostic purposes, plug only one X or Y motor into it’s corresponding port at a time and test it from the control panel. Make sure it moves in the expected direction and that the distance travelled is also as expected (ie. tell it to move 200mm - is it really 200mm?). Test each motor individually. When it comes to Z, if you have a dual-motor gantry, and if it’s convenient, detach the motors from the lead screws and test them individually. If it isn’t convenient, you will have to test both motors at the same time. Again, make sure direction and distance are as expected.

If you have a volt meter, measure the voltage on the limit switch(es) who’s indicator lights are dimming. I’m guessing these are active-low, meaning that they should have (probably) 5V across them when not activated and 0V when triggered? In most cases that I’m aware of, an LED would be in series with the limit switch, but then there would be no way for the LED to come on when the switch is not being triggered. Of course, as I write this, I’m realising you didn’t actually say where the print head was at the time the LED’s were coming on; perhaps it was in the “home” position and triggering the limits?

If the LEDs are operating independently of the limit switches, then they would have to have their own, separate power leads. I’m puzzled by your statement that they were “very dim as opposed to off”. At the time they were dim, were they supposed to be on or off? If they were supposed to be on, but were dim instead, then that would be an indication of a power supply being overloaded. Probably not the 24V main power supply, but a secondary supply on the controller board that provides 5V or 3.3V for things like the limit switches or LEDs. Generally, most printers (these days) run off 24 power supplies that primarily drives the heaters but also gets further dropped, within the controller board, to 12V to drive the steppers. That 12V gets dropped again to 5V and/or 3.3V to drive the controller chip, display, limit switches, USB port, etc. etc. If you overload the 12V port with, say, a faulty stepper motor, the 5V rail might be affected too.

For now, as I suggest, check your stepper individually and, while you’re at it, check the limit switch LEDs with each stepper motor to see if one of them is overloading the 12V internal supply.

My apologies!!! I guess I could have worded that a bit better and specified a few things.

The printer I’m converting is a CubePro by 3DSystems. It has Dual Y steppers to help move the all CNC Steel ganrty.
The Z axis is a cantilever style carrier with a single large stepper with a screw drive.

I reused as much of the stock wiring as I could because its all beautifully braided and ran nice. The Y motors are already wired to work as they should, just had to convert to standard JST connectors. The motors move as they should.

I don’t think I have the boards Config file correctly set up for steps and what not, I’m not quite proficient in this yet.

The limit switches luminate the LED to full when depressed in the active low position, but the limit switches are only 2 wire. I have them connected to GND and (X,Y,Z)Stop which triggers the feedback LED. everything homes as it should.

I will have to test my X stepper motor. When I unplug it the “dim led / backfeeding” issue goes away. Maybe that’s why I got my error message about my motor phase being disconnected on that driver.

I’m going to try to get a proper config going so I can diagnose a bit better

so I’ve got a way more solid baseline config file now. for some reason it keeps moving X and Y together. I’ve tried changing the header to E1 and still has the same result. I have now completely changed the cable to the X motor and again, no change. Is there something in the config that would make them both move during homing?

I’ve figured it out. And I’m just a dumbass. I had my config set for CoreXY when the machine is a cartesian layout. My apologies for the confusion!!!

A-ha! I hadn’t thought of that :slight_smile: Glad you figured it out.

A word of caution: you said the Z motor was a “single large stepper”. It might be prudent, if this stepper does not appear to be a standard NEMA 17, to look up the model number of the stepper it does have and confirm the voltage and current requirements of it to be sure your controller and stepper drivers can actually handle it.

1 Like