Is Marlin installing or not?

I’m new to this forum. I have a 5yr old CR10 (400mmX400mm) that I’m upgrading to a BTT SKR V1.4 Turbo motherboard, BTT TFT35 V3 touchscreen, BLTouch and filament detector. I’ve had excellent prints and was generally happy with my print results. After all these years I decided it was about time to learn Marlin and upgrade my printer. I must have spent 20hrs plus watching YT vids on Marlin, the BLTouch and TFT. So here’s my issue. Prior to transferring the wires from my old MB to the new one I was able to successfully install Marlin (Bugfix 2.0) via USB cable on the new MB. I also successfully installed the new updated Icons on the TFT!! I was able to switch the TFT from ‘touch’ to 12864. So I connected the wires, watching polarity and triple checking all wiring even from the cannon plugs. I was careful to switch the jumper from the USB to VDD. I turned on the main power and noticed X travel was reversed so went into Marlin and reversed that stepper. Put the .bin file on my micro-sd card (the .cur file was also on the card) and inserted the card into the MB. Turned on the power…nothing seemed to happen. When I looked at the card contents, the .bin file was gone & only the .cur file is there. I understand it is normal and is actually a sign that the update worked but I’m not sure whether it actually did or not. The 12864 screen states “USB Start Failed”? I don’t get it. Yes, the X travel seems okay now. So, my question is how does one know if an update worked when using a micro-sd card in lieu of the USB cable. Also, once the MB is installed in a control box, how can an update be done using the USB cable if you can’t get to the jumper on the MB or can we only updates using the USB card? Note: The BLTouch and filament runout haven’t been installed nor activated in Marlin. I want to tackle one problem at a time. Also, should we do firmware changes via the TFT USB port or the micro-USB on the MB? I’d appreciate any help provided.

So there is definitively a lot to go through here…
I have both that board and the new screen on my ender 3 pro. And definitively one step at a time is the way to go.
Most important of all is to wire it properly… Otherwise you will let out the "magic " smoke, and the board will not work anymore. It sounds like you have that part done correctly, but check these things:
Check that extruder, x, y, and z all move in proper direction.
Check that bed and tool heat up and register on the screen (temp goes up).
Check that the Hot end and parts fans work.
If all of this works… You are good to go.
You don’t need to switch the jumper for USB VDD… This does not disable the USB… just the power line. Once connected to the power supply, just leave jumper on VDD.
Next… I tend to stay away from “Bugfix” … That is the cutting edge, just built today version… Just take the main active version… I am using the newest one now on my CR10v3 and it is fine.
As for the version, check the date of the .cur file and it should be the same as the date of the bin file you used. You can also use the 12864 and go to “about Printer” and see the version. This will not help for small updates like the one you did since version stays the same in that case.
Since you will be doing a fair amount of firmware updates… I recommend the “Firmware Updater” plugin for Octoprint if you are using it… So much easier to load the firmware without the SD card (note you still need an SD card in the printer since the file is copied there and the printer reset).

Hope this helped a bit.

1 Like

Hi Steve,
Are you kidding!! Your reply has enlightened me tremendously. The reason why I used the Marlin bigfix is because that’s what is recommended in YT by guys like Teaching Tech etc. I was hesitant to use it because in the RC hobby we NEVER use a bugfix version of firmware, always the ‘official’ release. I’ll have to do my config over using the non-bugfix version of Marlin. I’ve since returned my Mboard to 3D Printing Canada, I bet you they’ll say there’s nothing wrong with it, must be the user and probably is?? So I’m pretty sure I get what’s going on here and your reply has confirmed so much. One other question. When performing a 4 corner leveling (using paper) the head travels to front left corner no problem but when I select the front right corner the head only travels halfway? My bed is 400mmX400mm but the printer head travels 200mmX200mm even though I changed the bed size in Marlin? That’s how this whole thing started…the firmware updates don’t seem to reflect the correct bed dimensions…or is there something else I’m doing wrong? BTW, all other printer functions, heating etc are okay. Thanks so much for your help!

I am a big fan of Teaching Tech…
Did you load the proper configuration.h and configuration_adv.h from the examples(CR10)? Also, you must use the right one’s. Before the copy, check the version in configuration.h and make sure it matches the one you have in the example file… they can be different, and are not interchangeable for the most part.

I use a BLTouch, so I have not looked at much of the manual leveling firmware, but with like most of this stuff… it is based on a fraction of the bed size… i.e. 0,0 0,bed_size/2 0, bed_size… and so on.

But there are offsets which maybe tripping you up if your example file was not added.


Yes, I copied several different config files (both .h and _adv.h) but couldn’t find anything fitting my requirements without run-out filament and ABL probe already ‘activated’. Not knowing what to ‘comment’ (//) was confusing and generated many errors when compiling. I ended up using the Marlin ‘bugfix’ version and configured it myself after watching many hours of YouTube vids to guide me. I know I’m getting close but since I’m not sure if things are updating correctly and not being able to adjust full X travel I’ve hit a wall.

Sorry for the late follow-up. Since my last posting I returned the board from where I purchased it and after a month of them not being able to figure out the problem they sent me a new replacement free of charge.
I ran into exactly the same problem but I think I’ve got it now except
for a problem with ‘Z’. I’ll do a separate posting for that.
Thanks everyone for your support and feedback.

1 Like