Marlin 2.0.8 eprom and bed issues

So ive upgraded my first printer to marlin 2.0.8.

It prints well, but if i leave it off for awhile it askes

Im also finding i need to relevel and reset the e steps.

I believe i have it set up to save eprom settings, but am unsure as to why this is happening.

My seccond issue is the print bed takes forever to heat up now. One of the things i wanted to try from upgrading the firmware was doing PID bed heat. So far ive decided to abandon that as it was slow to heat and i had a few heater fail messages come up.

My printer was working before the upgrade, and is currently working fine with bang bang bed heating. Its just really slow at heating which i think was a bit of my issue for the heater fail.

Any help for either issue would be greatly appreciated.

Fyi i have an adimlab gantry-s on a robin lite board v1.1 it has 4 steppers, a4988 integrated drivers, no abl, 12864 lcd screen, runout detection. Single extruder, and 24v.

It looks like the firmware has missed something printer specific. If you picked up one that was adjusted it might be worth looking for another persons version. If you adjusted it hats off. I am not there. I looks to me like something machine specific that should have specific settings got missed.

This one is all home brew. I have a hunch i need to adjust something related to power for bed heating, but jm unsure of what numbers i should be useing. I probably should try and compare some other compiled versions for similar sized printers.

My adimlab is my Frankenstein printer. Where im trying to maximise the limited capability of its control board, while learning the features and abilities of 3d printing.

1 Like

That sounds like a plan. I’d offer a suggestion if I had any I don’t have enough experience with software end to offer anything useful.

1 Like

It seems i dont have eeprom. But i double confirmed its defined. Ill update you all when i figure it out.

1 Like

Going to try a new version of marlin and see if that clears my issue

Ill be going from 2.0.8 to 2.0.9

BRUTAL I hate fiddling with the printer not actually printing.

Its frustrating at times, but i want to learn all i can about 3d printing at my pace, so its worth it. I have a prusa mini that just prints unless im useing filamentium iceland blue XD. It just grinds that to bits.

1 Like

LOL I have not printed the filamentium. Everybody’s favourite grinding filament and not feeding it. My artillery likes that trick. I have it solved but never quite trust it.

1 Like

just as a question, when you get the error about the eeprom do you have an SD card in the printer?

Marlin has been putting the eeprom on the SD cards lately and if there is nothing there to write it to It may throw the error?

The error happens when the sd with the eeprom file is not there. Ive accepted my losses and just use the same sd card now. Though im updating to an skr 1.4 turbo so ill see if i still have the issue.

Hey Dr

Glad we at least have a reason for it, although not a good one…

1 Like

Any idea of when marlon started saving to the sd cards? Ive tried 2.0.8 and 2.0.9 which both saved the eeprom to the sd card, even though i had it defined in marlin. Im also very sure the mks robin has more than enough room to save eeprom and i could save to it before.

I am not sure exactly when, but in the 1.X it was for sure saved onboard. Became an issue when they started adding features like power loss recovery and the BLtouch. Just was not enough memory to do it all,

At the time they decided to move the most volatile items onto the SDcard and the EEprom was it.

Was an easy way to clear up 900Kb of memory.

1 Like

That would make sense then, as i think my stock firmware was a 1.x version.

All in all, no regrets going to 2.x

Lots to learn, and happy to share it with others.