Mesh levelling with CR Touch

I have an Ender 3 Pro with CR Touch installed.

Anyone know how to get this to mesh level the bed? I’ve found how to do it manually, but can’t find anything on how to do it with the CR Touch. I swear I saw a video where the guy did it, but for the life of me, I can’t find it.

I think this is just for interest’s sake. The auto levelling works great. I’m curious, though.

Anyone got any information on this?

Any help is greatly appreciated

HI Andy

The CRtouch and the BLtouch are basically the same beast. BLtouch was the creator of the product and many others have copied it. To be honest it just works.

In order to use Mesh bed levelling at the start of your prints, you need to modify your start Gcode.
In it you will find a line that has a G28 in it. Add a new blank line just under it and create the command G29. This will start the mesh bed probe at the start of every print. Once you have the bed probed and there is a saved mesh in EEPROM you can use either the G29 S1 or the M420 but for now to verify it’s working correctly insert the G29 and let us know if its working OK.

1 Like

I don’t have the Pro but the 3V2 with a CR touch. I bought it instead of the BL because it seems to be built tougher, has a spring to hold the plunger up when not in use, not a magnet (which fails at times) and has a metal probe.

With the 4.2.2 motherboard I upgraded the firmware to the Jyuers UI, plus the display drivers and with that their are several built in methods of levelling in various ways including the mesh. Levelling very accurately is very easy now. I don’t know what your Pro has but if possible do the upgrade to Jyers.

1 Like

G29 worked well. It probed 9 points and is currently printing five test cubes, very successfully.

I was looking at the G29 and M420 commands and there is a confusing myriad of options.

Thanks for the help, it is always appreciated

Andy

hi andy, the G29 and the M420 both do almost exactly the same thing, in most firmware the commands are interchangeable.

when you run a G28 to home it disables mesh bed leveling(I know there are firmware options to change this but Default behaviour) You must run either a G29 or an M420 for Mesh bed leveling to be enabled.

You can enable it by running G29 which will probe the bed, or G29 S1 which will read saved mesh from memory slot 1.

M420 is similar but each with there own mesh options.

Cool! I’ve never been one to see how fast I can print, I’m more interested in quality, so probing 9 points before a print doesn’t bother me.

Thanks for the help! Much appreciated!

Happy New Year :partying_face:

Andy

1 Like

no Problem, anytime,