Micro-Swiss Direct Drive Extruder on Creality Ender-3 Max

I’m installing the Micro-Swiss direct drive extruder(For CR-10 and Ender 3) on my Ender 3 Max.
Unfortunately, the fan housing on the Ender 3 is quite different, there are no holes on the Micro-Swiss extruder that line up.
Has anyone run into this problem before, and how to fix it?


HI @era99

Generally with the micro Swiss I will print the petsfang fan setup for my fans, Opens the nozzle up a little better than the original one and allows you to see the first layer going down at the nozzle.

Hope this helps

Thanks, Jason!
Obviously a question I should have asked BEFORE I started the mod…
I’m going to see if I can kludge something together so I don’t have to go back to the Creality original just for this print…

@era99 no problem, I think there should be a warning on the box “please print a shroud if required BEFORE taking your printer apart”

it does happen a lot, including to me. Its just so exciting to put new shiny parts on your printer…

Here is my current fix - to get myself printing with the Micro-Swiss.
It’s an aluminum plate that holds the original fan housing.
I’m currently testing the new hot end and extruder, and getting everything calibrated.

Further to this upgrade.
I have set new esteps and axis offsets, and saved them to eeprom using m500. When I did an m503, the settings were there.
However, they seem to get reset, such as overnight.
Is there anything I should be doing differently?

Obviously, the original esteps of 93 causes under-extrusion, and the lack of x & y offsets causes the printer to try to print off the front of the bed.
I have worked around this by going back to the original Cura G-code for the Ender 3 Pro, and putting extra steps in the G-code to explicitly set the axis offsets.
However, I was hoping that I could have everything saved in eeprom!

Sorry, wrong photo.
Here’s the correct one

most of the eeprom settings now are stored on the SD card, so if you need to save eeprom settings the SD card has to be there, when you save it, it goes to the prom. Next time you boot reads off the prom and loads to the EEprom again on the SD card.

Long and the short, SD has to be there when you save and boot.

Alternative is to add the M92 and M851 into the start Gcode script whenever you do slices and that way its always there for every print. If its already set it won’t throw an error or cause your print to fail.

Is that the .DAT file that I see on the SD card? I was wondering where that came from!
I deleted it when I was cleaning up files on the SD card…
I’ve added the M92 commands, I’ll add the M851!

hi @era99 yes that’s correct, its where all the temp memory files are stored.