Modded Mega Zero keeps grinding nozzle into print

So I have upgraded my Mega Zero over the past two years. It has dual Z rods, heated bed, linear rail on the x carriage and a BTT skr mini e3 v3.0 along with a tft35 touch screen. But now I get this Great first layer, but the rest becomes a hot mess that has destroyed two glass plates and a bl touch probe. It seems like the nozzle doesn’t raise up high enough on layer changes and grinds the nozzle into the previous layer. No clue why this is happening. The only thing I can think of is that maybe the two Z motors are maybe missing steps? I didn’t do much with them except install them. I have calibrated e-steps, PID autotune, z-offset, I use ABL, and the problem is still occurring. Any ideas are appreciated

You could be missing e-steps but you need to provide a lot more informaton:

  1. How are the motors wired and how did you set the current for them?
  2. Along with that, what are the stepper drivers and what are the number of microsteps set for them?
  3. Does the gantry move easily up and down?
  4. What firmware are you running? Where did you get it?
  5. Have you tried turning the motors (with the lead screws) by hand and is the amount of friction equal for both?
  6. How are the lead screws attached to the motors?

Sorry, but there are a number of things that could be causing the problems and that means that there are a number of questions to figure out which ones should be investigated.

  1. Im not sure what you mean by wired. I made sure they worked. Definitely didnt set current for them.
  2. Driver is TMC2209 and I have no idea. One driver runs both Z motors
  3. Yes. Moves up and down fine.
  4. firmware is Marlin bugfix-2.0.x. Got it from BTT Github.
  5. Yes and they move fine as far as I can tell. The mount bolts for one of my anti backlash nuts were loose so I tightened those up.
  6. They are connected with z couplers.

And please dont apologize, you are helping me out and I appreciate the questions. I have only been printing for about two years and I started modding about 6 months ago.

Questions back at you:

  1. How are they connected into the controller board? Is there one cable, two, what connector(s) are you connecting to on the controller board?
  2. Can you look for a current setting in the user interface? If it was built to use the TMC2209s, then it should be there.
  3. Good.
  4. Where did you get the firmware and did you build it yourself?
  5. Good.
  6. What do you mean by “Z couplers”? could you post an image of them? How do you know that the leadscrew won’t slip in the coupler?
  7. New question: When you have the gantry move up, what happens if you press down on it? Does one or both Z axis motors stall easily?

My first guess is that when you added the second motor, you didn’t change the current setting and each motor is only getting half of what the one motor received originally. Hopefully, if you’re using TMC2209s and the serial connection is enabled, it will be a simple task to increase the current so things will work okay.

  1. one wire bundle made up of four wires per motor.
  2. I will look when I get back
  3. Firmware from BTT github and yeah I configured and compiled it myself.
  4. This How to install the z-couplers (the right way) [3DPrint.Wiki]
  5. Ill check when I get back.

Im beginning to suspect that myself.

  1. Z current setting is 580.000
    Extruder is set at 650.000 for some reason.

  2. Yeah one motor stalls out immediately when I press on the gantry.

A few things back. Note that I’m going back to my original line numbers so we minimize confusion.

BTT SKR MINI E3 V3.0 Pinout diagram:


Marlin Firmware:

  1. I’m not getting the answer I’m looking for here. What I’m trying to understand is how the two Z axis steppers are wired to the controller. If I look at the pinout/schematic you should be connecting one motor to the ZAM and the other to the ZBM connector - is that what you’ve done? If you have, then the motors are wired in parallel to the driver but I need to confirm that’s how you’ve wired things.
  2. If things are wired in parallel as per the previous question then your motors are wired in parallel and each one is getting half the current of one in the original set up.
  3. Gantry moves up and down easily. No binding.
  4. Did you get the firmware from the link above?
  5. Motors Turn easily in the system.
  6. As well as following the instructions, did you align the motors so one of the screws in the coupler tightens onto the flat spot of the motor? Did you file or grind a flat spot on your lead screw?
  7. So when the gantry is moving upwards, you can stall it easily by pushing down on it.

So based on your most recent reply with:

“Z current setting is 580.000” and " 2. Yeah one motor stalls out immediately when I press on the gantry." I think it’s most likely that you are not providing enough current for the two motors.

Maximum current through a TMC2209 is 1.4Arms and it seems that the current specification in Marlin is in Arms so I’m going to suggest that you increase the Z current setting to 900.000 and see if that makes it more difficult for you to stall a motor when you press on the gantry.

If it is, I’d like you to try another print (using one of your ruined surfaces) and see if you get the same problem. I’m crossing my fingers that increasing the current solves it.

  1. Yes one is connected to ZAM and the other to ZBM
  2. Yes. But I configured and compiled myself. I didnt use those .bin files. Its on the BTT github somewhere. I cant find it atm.
    6.Yes. and not grinding.

Ill try bumping up the current

I bumped it up and now its much harder to stall out the one motor, but it still happens.

What value are you running at? Have you tried a print?

If it still happens during a print, you could try as high as 1.100 (which is basically double what you had before) but wait to see if you have the same problem as before.

It seems to be working fine now! Should I bump it up to 1.100 to be safe?

im running at 900.00 currently.

Leave it at 0.900 if it’s working fine.

The higher you set, the more current will be drawn, meaning the driver and the two stepper motors will get hotter and you could have problems down the line.

I’m glad to hear things are working well - I’m looking forward to seeing what you print!

Thank you! now I have to deal with odd layer shifting in the y and x axis. Which is odd because my x axis has a linear rail and the y sits on two rails. im thinking it might be belt tension.

Check your belt quality. I had some cheap Chinese belts on one of the printers I designed and had quite a bit of problem with the interior strands breaking and getting some odd layer shifts.

I switched to Gates and the problems went away.

Just bought some. Thanks for the help. ill show you when im done

1 Like