Need help with new motherboard and Cr touch install

Hi, I am new to some of this but decided to upgrade my motherboard on my Ender 3 to the Creality silent motherboard, the 4.2.7 I believe. And add a Cr Touch at the same time.

I installed everything and grabbed the firmware that seemed to be the best fit from the creality sight and flashed it…

My issue is when I try and do the auto home now the nozzle drives into the bed and tries to keep going.
I haven’t figured out a better way to stop it so flipped the power off switch as it is making awful noises from the Z axis motors ( I have dual z ballscrew setup ).

I tried doing the Z offset as described in the instructions and put that in, but it still crashes every time.
I have no idea what to do next, hopefully someone here has an idea?


So, I managed to get it to home.
I reflashed the firmware and tried doing the Auto Home, it still tried to drive into the bed, but this time I noticed that the CR Touch was out and trying to detect.

It didn’t seem to be low enough to detect, so I added a washer on each side between the cr touch and the mount.
This time it seemed to work properly.

1 Like

Same problem I ad with my Ender 5 plus (that led me here for help). Mine was mostly solved by printing and fitting an appropriate fan cover (which alters the CR touch) and installing the correct firmware. Maybe a search for an stl file for your printer?

Biggest problem I had was Creality fitting ‘instructions’ which weren’t.

thanks Plug, I will take a look

You are right about the instructions, they are lacking!
The firmware download area would benefit from a little more description as well lol

thanks for the reply

1 Like