New version Cura 4.9

So I’ve been printing these parts in eSun white PETG for the last few days and the printer needed some tuning with this filament compared to what I was using before. Getting stringing more than usual and the occasional blob that I hadn’t before so since these are small parts I was going to print them one at a time this morning making changes to tune it but this new Cura update hit and I installed it. Well it’s like starting over, so I have to put the printer profile and materials back in… I transfered my start gcode in but the next print screwed up because the filament temp is too cold. when I look and compare the V4.8 and V4.9 Gcode there are some differences at the beginning. My nozzle temp should have been 230 but ended up at 205.

The beginning of the old and new Gcode files:

;Generated with Cura_SteamEngine 4.8.0
M82 ;absolute extrusion mode
; BIQU B1 Start G-code (after this is all my usual start Gcode which worked fine before)

;Generated with Cura_SteamEngine 4.9.0
M140 S70
M190 S70
M104 S230
M109 S230
M82 ;absolute extrusion mode
; BIQU B1 Start G-code

In the 4.9 version its telling the printer to set the bed and nozzle temp correctly before loading the insertion of my start Gcode, I think my own start gcode should override this but where it’s ready to start printing, after the ABL stuff is done I have M104 and M109 in there to get everything to printing temp (in ABL I have the bed at one temperature every time it starts) but in the V4.9 it’s erroneously setting these to 205° and I have no idea where that number comes from. In the Filament properties there is a park temp for this filament that is 205° but I don’t see how that is being passed to Marlin, there doesn’t seem to be a command for that in the gcode. normally the bed and nozzle will take the settings for the material from where you put it in the slicer and will be in my start Gcode, it has worked every time in V4.8 but obviously I’m misusing this in my start gcode some how because something is overriding it with the wrong value.


I would suggest hooking the printer up to a terminal and manually entering each line of code to see which one is setting the temperature to 205°C. Sometimes, when programming microcontrollers (and, let’s face it, that’s basically what we’re doing here albeit at a higher level), they only way to catch a glitch is to single-step through the code.


That, is a great idea!

Figured it out but can’t really fix it. If you look at the beginning of the gcode that I posted above you see all the temperature stuff that cura put at the beginning of the file. That used to go after the start gcode, when the sliced file is supposed to print. So the settings from the slicer for temperature are at the beginning of the file and being overridden by the printer start gcode in which I warm up the bed to do the ABL routine then print some purge lines before it starts making the part, Those generic middle of the road temperatures is what it tries to print with.

cat modelname.gcode| grep M104

Lists all lines containing M104:

M104 S200
M104 S0 ;Turn-off hotend
M104 S0

sed -i “s/^M104 S200.*/M104 S240/g” modelname.gcode

Changes all lines containing M104 S200 to M104 S240 or whatever temperature you wanted.

Repeat for the bed if necessary with M140 instead of M104.

This is with the Linux command prompt. Using Search/Replace with a text editor will do the same thing.

Yes for sure. For a second I was excited that you were saying I could use script commands inside Marlin… I’d like some timers please heh.

HI Guys

I personally use CURA every day, both at the shop and at home. I got really annoyed with Cura at the 4.6 upgrade. I had about 20 different machines setup in my profiles so I could choose the machine based on what I was doing, )size, nozzle, retractions, direct drive… etc. I installed the 4.6 and cura decided I didn’t need all of those machines and deleted them for me, I don’t think I have ever recovered from it. At least not the way it was. Since then I have always been very careful about Cura updates. I cannot complain cause at least they update it (unlike others I could mention) but they need to change that overwrite everything mentality.

1 Like

or at least be able to export the configs so they are backed up.

I installed 4.9 on another machine and it doesn’t do this. One install I can’t make it happen on another I can’t make it not happen. heh

1 Like

I know what your saying, Its not predictable at all.

If they installed it in a new directory every time and all you had to do was move over your “config” directory and move on I would be fine with it, but randomly it installs in a different directory and deletes your previous config… frustrating

Well, I reinstalled this and it works as normal now, so there somehow was a glitch during installation that made this small odd problem instead of hosing the whole thing… I think this behavior is what you would get if there was no start gcode. it sends these lines to set the temperatures before the print starts and in this case, it was doing both

perfect, thanks for the update, It is truly an unpredictable problem