Printing Letter Issues

Hi everyone, and thank you in advance for your help!

I hope that I started this topic in the correct area, if not please let me know! As you can see in the below photo, the printer (Ender 3) works more or less correctly, but I’m facing with an issue every time I print and I try to add letters. It always leaves some space without cover of the PLA filament.

What I tried: Changing temperature of the PLA / PLA material / Changing wall configuration / Slicer, etc

Can someone help me?

Maybe try this setting, I usually do not have the problems with gaps in letters.

Hello HobbyMaker3D,

First of all thanks for your reply. I’ll try your suggestion during this weekend. I have not seen that option before, so thanks a lot. Once I do a print I’ll by able to tell you if your suggestion worked!

Thanks again!

1 Like


I manage to do a print today and the issue is still there. It seems that is going better, but you can clearly see it.

I attach here another picture

Do you have any other suggestions?

Thanks I’m advance!

There are two others setting I always use. These may help closing the gaps.

1 Like

Yes I second this, give it a try and see if that helps!


Hello to both!

I’ll try this on Monday, as I’m out of home during the weekend, but thanks in advance for your quick help!

I’ll update you on Monday!

1 Like


I did the suggested changes, but as you can see in the picture, still having the same issue… Do you think if there is any other possible options / issues?

Thanks again in advance!

Can you share your .stl?


Yes sure, but the problem is not only with this file, but in general.

Here I added the STL and the gcode that I used.

Thanks in advance for your help!


I ran you .stl file through Cura and found this.
The settings of line width of 0.4 show small lines in middle of the letters. When I changed it to 0.5 the lessened. Sometimes the font you use can cause problems. I have found hat Arial Narrow works well with 3D printing.
Give it a shot. See attatched.

1 Like


I just tried your .stl in ABS with my standard setting(s) and here are the results I got:

The percentages is the extrusion factor as I’ve found it to cause blobbing in the past, but not for this model. Temperature is 230C, Bed is 80C, speed is 50mm/s, retraction 0.5mm and pressure advance 0.1325.

You might want to look at changing your retraction value as there may be a problem here. You can also vary your extrusion factor to see if that helps any.


One more data point - I printed the tag again in PLA:

Temperature 225C, Bed 60C, Micro Swiss NG extruder, 50mm/s speed, 0.2mm retraction with the extrusion factor written on the pieces.

I used a custom designed direct drive toolhead on the previous ABS prints (sorry, I should have noted that).

I don’t know what else to say other than look at your retraction settings - maybe experiment with them a bit.

1 Like

Hi all,

Thanks for your message and for the test prints that you did! I really appreciate it!

I’ll do some test in these days with your suggestions and I let you know if I managed to resolve the issue!

Thanks again, I truly appreciate this!

1 Like

If you are using Cura, I would suggest to try the “ironing” option for the top most layer. If you printer setting is dial-in correctly, this would help to close any gap at the top.


Thanks!! I did some tests and improved a little bit the print

I’ll try your suggestion on Monday, as I’m out for the weekend!


Hi All,

Thanks for the great help!

Sorry for the long time without writing, but I was very busy and I didn’t managed to had the time to experiment. Now, had the time to test it and I think with the Ironing part it solved the main problem!

The only thing is that now the lines seems to be very visible and other minor issues, but this was a great advance!

Thanks again for all the help!