Pronterface Error 2

Hello All … I’m having an issue with Pronterface and hoping someone can guide me to resolve the issue.

When I try to connect my Dell Laptop Win 10 to my Printer … I get the Error -

[ERROR] Could not connect to COM3 at baudrate 115200:
Serial error: could not open port COM3: [Error 2] The system cannot find the file specified.

Would really appreciate any help with getting my Printer hooked up to use Pronterface

Thank You in Advance


It could be a few things.

  1. is it the correct baud rate?

  2. is it the correct com?

  3. do you have the correct driver for your printer installed.

Im not sure which printer you have, so ill assume an ender 3 as a standards. Though these concepts should apply to most 3d printers running marlin.

  1. on your printer there usually is a way to see your printers info. That should say what baud rate the printer wants.

  2. to check which com your printer is useing by going to device manager. I tend to poke around at things so im going to let this article explain it a bit better.

  3. lastly which i suspect may be your issue is drivers. If your printer came with an sd card/flash drive, check its contents. For whichever reason, 3d printers seem to be particular about their drivers. If im correct to assume an ender 3 then a simple google search for its drivers or checking crealities website should locate them if you dont have them on your sd card. If you have another printer, id google its manufacturer just the same.

If that still dosent help, then let us know what control board your printer has and we can try helping you find them from there.

Hopefully this helps, i had a frustrating time getting my printer to talk to ny computer for the first time, but my issue i think was drivers.

1 Like

Hi Dr. Marvin … Thank You for your response … the Printers I have are Artillery Sidewinder x1 … after doing much more research … problem solved.

In case someone else has the same issue … my printers did not come with printer drivers … but what I did do was install CH340 Drivers and after setting the Comm port to the highest baud rate connection established :slight_smile:

Now I just need to dial in Z offset !

Thank You again Dr. Marvin I appreciate your input

Take Care

1 Like