Prusa z-leveling changing spontaneously

Hi everyone, I’m having a very weird issue with my prusa. I just had it in the shop for the second time in a month. They replaced the bed and hot end thermistors. I have had one successful print in the week since i’ve gotten it home.

The first was perfect then the second as soon as it started it was obvious the z-leveling had gone off…the printer hadn’t been moved, file sliced same way as the previous one…but suddenly the filament was not even close to laying down…

I adjusted the z-level and it seemed fine…i did a print…it was good but not perfect…then I did one last night…I started it and seemed to be ok…nothing had changed…i had to step away for a few mins…I always check the first layer every few mins…and i came back to the nozzle grinding on the plate…wth…(see pic) the z-level way off again…

I fixed again and started a new print and it seemed better but got these bumps and lines…finally stopped the print and did 5 squares trying a few diff temps for material and the bed…not a huge difference except at the lower temp i seem to get little clumps (look like a elevated line)

Using Petg at 240 - new roll
bed at 95 (and tried at 85, 80)
room temp is constant at around 21-23, no drafts and its partially enclosed.

I thought i got it working finally and then…not sure what the hell happened this time.

Has anyone else had an issue with the z-level suddenly changing like this? I can only imagine its a software issue?

I’ve had this prusa 3 years and it was a workhorse but it hasn’t worked right for 6 weeks. After having it in the shop twice already I am just about ready to give up on it.

Any help would be greatly appreciated

I am not sure but does PRUSA store EEPROM data on the SD card the same as most printers? My initial thought is if you switch SD cards without saving changes to the EEPROM it will resort back to whatever is on the SD card or whatever is stored in EEPROM if no SD card exists.

Some printers read it on startup some read it on the execution of the Gcode file.

Guess the question is do you use the same SD card all the time or do you save changed to EEPROM when you adjust the offset?

I would do a couple of things:

  1. whenever the printer is moved, or if you had a jam and had to pull filament out of the extruder, you might notice that the z-axis can move independently when the printer is off. This kind of thing affects the z-axis enough that you should perform a z-axis calibration. Other tell-tale signs that the cal is needed is when you get un-even first layer.
  2. Do a clean slice of your model with the PrusaSlicer defaults for PETG and default MK3S profile. If you see “modified” after your MK3S profile, something has changed, and try that.
  3. It looks like your first layer might be a tad low. I would raise it and perform a 1st layer calibration.
  4. Check, when the hotend is cool, by grabbing the hotend block and see if it wiggles within the extruder housing. It should be firm, not loose.
  5. Check the PINDA to make sure it is also held firm on the housing. If it is loose, it could mess up the bed leveling. It might be too far away from the bed and good live z numbers would be around -1 to -2. Anything greater than -2, means the PINDA can be lowered, and a z and 1st layer cal would need to be performed again.
  6. Are you using the sheet profiles? You might have satin and PEI sheets along with the textured one in the picture. If you have not been doing so, create your profiles of the sheets on the printer as these will have different 1st layer heights and be sure that you have the correct sheet selected before you start the print.

You mentioned you had both thermistors replaced. I would conform the shop had replaced them with the correct ones, I think it is the 100k the printer requires. When the printer is on but idle for the day, do both the hotend and bed temps appear equal and at room temperature? If not, this would indicate the wrong thermistors were replaced which would affect the quality of the print and bed adhesion.

Sorry for the lengthy troubleshooting. Probably too much here. Let us know how it works out.

I don’t have a lot of time I did not read the other reply so excuse if I am repetitive.

It looks like the head is too low. Is the PINDA loose? Is the PINDA bracket bad. It it moves the calibration moves with it. The bracket is one of the places where I wish they did not use a printed part it just is prone to breaking.

Did you contact Prusa support? They were really fantastic when I felt with them.

The Pinda was a bit too high according to Prusa…I spent 2-3 hours with them yesterday and still no joy. I readjusted the Pinda with no real improvement. I would do a 1st layer calibration…it would look great then i’d redo the exact same file and it would be off again.

new clean slices…same issue
hotend is stable and solid no movement.

tried a new SD card no difference

wasted most of the day yesterday redoing the first layer over and over and over

that is odd. I can’t get my head around how settings can change like that. Its the same heat bed sheet? Sorry dumb question but you never know. I have textured satin and original they are all slightly different. Sorry I am not very helpful.

It isn’t something in the gcode files? Or attached to one pre set ?

Grasping here.

Have you tried printing something else other than this object? It almost sounds like the object is not flat on the build plate in PrusaSlicer when it is getting sliced and its part of the gcode. Try selecting the object and select “Place on face” from the icons on the left side of PrusaSlicer, and select the face that you want on the bed, and re-slice.


On a new project add a box shape, unlock it and adjust the size so that it is a 50mm square by 0.2mm Z high. Slice that and print to see if you get the same results after a good 1st layer calibration.

just throwing a quick side thought in here. Anyone know what it looks like when the Pinda sensor starts to fail? I know with a BLtouch I will run a G29 multiple times and I can usually get it to give me a fly point or 2. Generally a signal the BLtouch is “sticky”

Does anything like this happen on the Pinda? Maybe run just the G29 3 or 4 times without changing anything and see if the results are the same or at least extremely similar?

I would replace the pinda probe.

hi @Brnbar01

Welcome to the forum, Glad to see you here.

Thats kind of what I was thinking, I cannot think of anything software-wise that would cause that kind of symptom, I figured it’s gotta be hardware.

The printer has sat unused for almost 2 months. I have had it in the shop and they replaced the thermistors and the PINDA was newly replaced before this. I had one successful print since. This is beyond frustrating and i’ve just about given up on the printer. I spent hours adjusting it with Prusa and had it in the shop there twice. I am going to bring it back in again as a last desperate effort to get the bloody thing working but next stop after that is the dump.

HI @hawleyk

Please do bring it in, Let whoever does the intake about this thread in the forum to review. If it’s something we missed we will own it, not an issue.

Sorry you are having the problem, we will figure out what it is.

Any chance you can bring in the SD card with it and leave your code slices on it? At least we will be testing with what you are printing and make sure it’s predictable for you.

I am thinking about this one, I am guessing something is loose somewhere.

(note to me; Broken bent Pinda mount?, Failing pinda sensor? Check firmware rev? stretch but maybe loose throat? Doubtful that it is slicer or filament, Pic 2 looks too close but parts of Pic 1 look high, check G29 output hot vs cold bed, will show diff in Pinda output, Check if the sensor is Pinda over Minda, Bent or loose bed rod mounts?, Broken Z axis bearing mounts?)

My PINDA holder I broke at one point it kept slipping. All I got. My Prusa and the ones at work (that is a bunch) are print and walk away. I never check the printer, I send a file and forget it. The amount of failures I can count on one hand.

Jason, I brought the Prusa back in, tried to explain the problem. I picked it up, they said they just had to run the calibration again. I did a test print it worked…did a second yesterday and it was ok…there was a fair bit of stringing as i think the filament may have been a little wet so i dried the filament and did the same print again…SAME problem. As soon as the printer started it sounded off…the Z-level was off again…I had not moved or even touched the printer since yesterday when I had the last print…it printed so close to the bed that it scratched it and the filament is almost impossible to get off now.

I am attaching a pic of the mostly successful print… and a print of the problem print…

i did notice that as it started to print the Z display had a ??

this has been since Feb since I had a successful print. In the shop 3 times now and hours on with Prusa chat.

what is wrong with this printer

Are you running Prusaslicer?