Run away Zoffset on CR10-S Pro with BLtouch

Recently my CR10-s Pro (V1 wiith BLTouch upgrade) started playing up. The Zoffset has gone haywire. And all attemps to bring it back fail.
Does anyone have a solution?

Got anymore info on what it’s doing?

Mine once couldn’t save the z-offset’ I was setting and reverted back to the stock z-offset (3mm above the bed) and ignoring any changes I made on the LCD menu everytime I tried to print (even though it would list it as changed on the LCD…).

I wound up changing the SD card and saving the offset using terminal commands, as it just wouldn’t save properly through the LCD menu. Checking and setting my offset through terminal commands via octoprint worked at the time. I’ve since re-flashed my firmware and it’s back to working from the LCD.


Sure. I’d just finished a print succesfully and wanted to start a new print. But when it started with the auto bedlevelling, I saw the extruder going up after each measurement. I tried the correct the offset usiing pronterface, but the printer had lost any reference to the original Z0.
I now have installed the firmware from Nic Wilson, but it still fails.

I just discovered, that the two wire connection was in the wrong place: where withe the original update this went to Z-, in the new setup it goes to Z+.
Trying again…
2 hrs later and the printer is whistleling away :hugs:

1 Like