Safe homing - M851 problem

Hi Guys

Having a bit of a brain moment and need to ask a question

have a machine with 100% custom firmware, Marlin 2.X firmware. Do not have access to the source code.

Printer homes X and Y ok, when it homes the BLtouch is off the edge of the bed, consequently, the probe extends properly but never touches the bed to properly home the Z-axis.

I was thinking about updating the M851 with the proper offsets but I think Im going to end up losing X and Y printable area because of it.

Can someone confirm that my thinking is correct or am I committed at this point to repunch the firmware from scratch and enable safe homing on it?

If the BLTouch is not crashing into the plate, then it must be using a limit switch on the Z-Axis, or it wouldn’t know when to stop. Either move the limit switch or, as in the case with an Ender 5Pro, adjust the screw (or whatever component) that triggers the limit switch.

It briefly occurred to me that it could be using soft limits but software-defined limits still need a physical reference point, so it’s not a software configuration problem.

It also occurs to me that, since you didn’t specify what the machine was, it is possible it’s not using an actual BLTouch. I realise that you, above all, should know what a BLTouch looks like, but it’s also possible you’ve become so accustom to the label “BLTouch” that you could be applying it to any similar product - much like we do with “Kleenex”.

My point here is that, if the probe is not an actual BLTouch, and since we (the readers) don’t actually know yet what machine this is, there is the possibility that the probe is a capacitive or Hall-Effect type and is responding to the proximity of the metal in the base plate. I understand these two types have an electronic adjustment to tweak their sensitivity.

1 Like

LOL I hear ya, Its actually a Ender 5 plus, factory installed BLtouch and it does function properly, If I manually touch the probe the bed does stop and attempt to probe the second time.

The problem is the location of the BLtouch when it attempts the probe. When it homes X and Y the BLtouch is behind the bed, problem is I think when the firmware was origionally done they did not enable safe homing, just wondering if I can get around it by setting up M851 and not lose bed size.

It still brings me back to my original post and question: what causes the nozzle not to crash into the bed? If it’s not hitting the bed during homing, then there would have to be some kind of limit switch somewhere. Move the switch or adjust whatever hardware triggers it (a screw on and E5Pro, for example).

While trying to look up how the Ender 5 Plus handles it’s Z homing, I stumbled across this post on StackExchange:

1 Like

I found that post but It looks like that one is a BLtouch failure.

The nozzle does crash into the bed just killing the power before it does any damage.

The bed layout is as I am trying to depict below but the “B” is where the actual bltouch sensor is when it’s trying to hope. “C” is where I want it to be when it homes ideally. but I could live with location M

You could always 3D Print a homing pad to mount to the frame below the heating pad at location B. Put an adjustment screw on it so you can fine-tune where “home” should be. Having it located off the build surface will preserve your build volume.

never thought of that, that may be a better solution than the day it would take to redo the firmware.