Sonic pad issue

I need some help with my CR-10 Smart Pro, I got a Sonic pad for my birthday and after weeks of talking with Creality and try everything I can think of, the Sonic pad will not connect to the printer with the usb cable? Any suggestions would be appreciated.

Have you updated the printer’s firmware with Creality’s Klipper firmware (NOT the genuine article)?

I don’t know much about the hardware you are working with, but the first thought that occurred to me, and I expect you’ve done this already, is check to make sure the usb cable is a data and power cable, and not a power only cable?

I’m following the Sonic pads instructions to do that, but it won’t connect to the the printer when I try to do that. So the answer is no.

I’m using the cable that came with the pad, so I can only assume it’s a data cable, I’ve tried a normal cable as well that I had for charging with the same results. As for hardware, it’s a stock CR-10 Smart Pro that I’ve had since March 2022.

Sorry, just to be clear, you’ve created a new SD card firmware image, leaded it into your printer and the connection still won’t work?

It is a USB A to USB B cable - I have never seen a “power only cable” in this configuration.


Could you outline exactly what you’ve done to try and connect? I know it should just be:

  1. Reflash the printer’s controller with the Creality Klipper Firmware
  2. Connect the Sonic Pad to the printer using the USB cable
  3. Start printing

but I think it would be helpful to understand exactly what you’ve tried.

Correct. I’ve updated the screen and the mother as Creality told me, still can’t load klippy as the sonic pad calls it.

Just doing a bit of searching. It sounds as if the biggest problem is having a printer.cfg file that is correct for the CR10.

Have you seen this:
Creality Sonic Pad - CR 10 Smart Pro Firmware

It seems to have pre-built firmware and a printer.cfg that is correct for the CR-10 Smart Pro.

If you’ve tried that, could you share your klippy.log file? Maybe there’s a clue in that.

I’ve tried all three of them. Two require downloading the files to a flash drive and the third just flashes from the pad. None of the configurations will let klippy connect to the printer. I can’t figure out what I’m doing wrong?

What are you using for printer.cfg?

I don’t know if this will help but I recently got a new iMac which would not connect to the same printer using the original cable because the iMac only has USB-C ports. So I got the proper cable but no luck. The problem was solved by installing simplify3d and using their connection wizard to increase the baud rate to 250,000 instead of 115,000. Perhaps you device is expecting a higher communication rate as well.

Creality’s firmware site to update to the most current firmware and the the sonic pad from there.

I finally got connected last night. Creality sent me a link to a YouTube video with the correct instructions for the Smart Pro.

Glad you got it working, help us out, and post the link Creality sent you.

Here is the link Creality sent me.

Please follow the video installation process to check your installation steps