Tried to fix one thing, created a whole new problem

Hey folks,

So my hot end fan on my Ender 3 V3 KE decided to go…and of course I couldn’t source a cheap one specifically made by Creality, so I bought some off of Amazon. They are 24v, 2510 fans. Of course, they had the wrong connector. SO…after a few youtube vids, and buying the write connectors, I learned how to splice and installed a new fan with the right connector.

Only now I haven’t seen the hot end fan run…at all.

To add salt to my wounds, my z offset is now messed up, and is sitting too high. I went through the bed auto level and auto-z offset, and it hasn’t worked. When the auto leveling was done, it showed a grid on the display of 25 squares. Each had a value with the highest being 1.69, and the lowest being -1.57. I have no idea what any of this means, and if the printer is compensating for it or not.

I am trying a factory reset, to see if that helps. If it doesn’t, at this point I don’t know what to do.

This printer is super frustrating. I’ve had it for what…not quite 3 months and it’s been a head ache that won’t stop.

Unless you blew the mosfet for the fan, it may just be wired backwards ?

The blue wire is the negative (or black on your amazon fan).

As for the Z offset issue, clear your bed mesh, then set your z offset. Then mesh your bed. If not you will fight the offset as the bed position will mess with it.

1 Like

Did the same thing when I replaced one of my fans, once i reversed the wires it was fine.

I did red to red, black to black…are you saying one of the parts may in fact be reversed?

Also, how do I clear my bed mesh, and and set my z off set? Then re-mesh my bed?

I don’t get how complex these machines are, and there is jack squat in terms of a manual for them? I don’t know what half the terminology is lol

Assuming you have a way to send console commands, and assuming it’s running Marlin (the default OS on most of creality printers).

I would start by sending a M502, then after executing that a M500.

What you have done there is set it to factory defaults.

There is a really good chance that this will solve it. But if it does not, then you need to set your z offset.

Here are some instructions on how:

  • Heat your printer up to your printing temperature and allow a few minutes for it to expand and settle
  • Reset the existing Z-offset to zero M851 Z0
  • Home all axes G28
  • Move the nozzle to the middle of the bed G1 X110 Y110 (if your bed is 220 x 220)
  • Turn off the software endstops with M211 S0
  • Move the nozzle down so it is just gripping a piece of standard printer paper
  • Set the Z-offset to the displayed value. E.g. if the printer displays a Z-Value of -1.23 enter M851 Z-1.23
  • Store it to the EEPROM M500
  • Important notice! Enable the endstops again with M211 S1 or the printer head will collide with the bed on the next G28 command

There are lots of YouTube tutorials for the Creality printers are they are one of the most common brands out there.

Yup! Wire colour on some machines seems to be more of a suggestion then a standard. Worth trying.

1 Like

Hey Norm, thanks for the advice, sadly that is so technical beyond my level of understanding you may as well be speaking Vulcan to me.

I have searched Youtube a lot for tutorials, unfortunately with the KE being new, the interface is somewhat different and thus older vids do not help me at all.

I need something written in crayon more or less.

The KE appears to be Klipper based.

Here is a video on setting the Z-Offset on the KE

Not sure if that helps ?