ViveDino Formbot Troodon SD1 Not working


I’ve recently purchased the formbot troodon from 3D printing canada. I’ve had trouble getting the sd card on the display panel (sd card 1) to read. I just get a message saysing “error 1 accessing sd card”. Does anyone have a fix for this? I’m trying to determine if this is a settings issue, electrical issue, hardware issue etc.?


hello Simon. I don’t have a troodon but lets start with some basics. Did the card come with the printer? if it is not did you reformat the card? What format is it? Typically Fat 32 works best.

Hi Kitedemon,

Thanks or your response. Yes the card came with the printer. Yes it’s FAT32. Yes I’ve tried reformatting, and also have tried other cards.

The screen works fine other than the sd card not reading. I’ve checked the slot for dirt but it appears to be clean. Maybe it’s a faulty connection? I’m not sure how the wiring for the screen works. I could dig deeper into the printer and check connections but I figured it would start here and see if it’s something easy/common issue

Hi Simon

Welcome to the forum, Glad you found us.

The Formbot has a hardware config based on the DUET Wifi 2 setup although they are custom boards in their machines. For the most part, the config/Wiring is pretty simple, a Single cable from the mainboard to the screen.

Usually, if it’s a weird issue such as this my gut reaction to it is wiring, Only for the part they are sea shipped and have gone from a super hot climate to Canada over 3-4 months. After the suggestion from Kite I would suggest laying it on its back and you can pull the base plate off, Simply unplug and plugin again the single wiring connector that runs from the mainboard to the screen. I believe on the screen there is a locking tab on the 10 pin cable, remove and reinsert and try again. Usually, this clears the issue but if not let us know here and we will continue to work through it.

Hi Jason,

Reinserting the 10 pin cable into the mainboard fixed the problem, must have wiggled loose. I didn’t pull the base plate off the printer…I was able to just slip my hand in through the front panel that the screen is mounted to.

I think removing the base plate and checking over all the connections would be a good idea, so I’ll plan to do this in the near future. The printer is running fine other than this one issue I had.

Thanks for you help,


HI @simon

Thanks for letting us know, I would like to say that hot glue solves all issues but unfortunately 3 months on a container ship sometimes things get a little shook up.

Glad you got it worked out, Hope to see you here often, Not with problems, just with cool prints. )