Vivedino Reptor 2.0 Homing X issue

Hello I am new to this forum and New to 3D printing. I just set up my Vivedino Raptor 2.0 running Merlin 2.0.5 firmware. I was following the instructions to setup homing and bed leveling but every time I run auto home the X value errors our and I get “homing failed printed haulted please reset.” I tried Youtube for solutions but nothing has been working. the following link is a short 0.25 second video showing my homing problem.

Thank you for your help!

2 things. 1 is the z axis connected correctly. See if you can select move axis and if itll move.

2nd thing is Tom Sandlander did a video on the raptor i think and i think it wasnt reviewed too well. Double check your wiring, and be particularily careful if that is the case.

Your X-Axis limit switch is disconnected or defective.

I don’t know this printer, so what I’m describing may not look quite the same.

Somewhere on the left side, there should be a switch of some sort. When the carriage reaches the left side, it presses on the switch to indicate it has reached the end. There are several possibilities:

  1. Check the cable for the limit switch all the way along. Make sure it’s firmly plugged into the limit switch. Make sure the cable doesn’t have any breaks. This can come from the cable getting pinched in the mechanism and partially sliced through. Check the cable all the way to the controller and make sure it’s plugged firmly in at that end too.

  2. While most printers that I’ve seen just have the limit switch with a (usually metal) arm that sticks out and gets hit by part of the carriage body, there are some cases where the manufacturer uses a pin or blade of some sort to press the switch. This will definitely be the case if the manufacturer has used an optical sensor. In that case the blade or pin has to pass into a hole, or through a slot, to block the passage of light to trigger the sensor. If your printer is using a pin or blade to trigger the sensor, make sure it isn’t bent or misaligned.

  3. Similarly, the limit switch itself may have an adjustment screw to allow it to be re-positioned so it can be contacted by the carriage. Make sure the limit switch hasn’t been knocked out of position. Sometimes it’s only a matter of a mm.

  4. The limit switch itself may be defective. If you have an ohmmeter (multimeter), check for continuity across the switch contacts. Most switches are Normally Open (there should be a high resistance when it isn’t being pressed) which drops to a low resistance when it is activated.

1 Like