Will not power on

I just got my ender 6 yesterday and after putting it all together it does not power on.
I checked all the connections and they are good.
I checked the Fuze by the plug and it’s good
I tried a different cord and still no power
I found a few videos and checked all the connections to the main board underneath and they are fine.
I do not have a voltage tester as shown on one of the videos I watched but on the power supply in the video it showed a green light on the power supply near the connections. My light is off and seems to not be power ed the light on the main board is also off.
Just wondering if there is anything else I should check


Do you have the power supply set to 115 volts?

There is a little red switch on the power supply it might be on “230v” Instead of “115v”

OMG thank you so much, I can not believe I missed that. I swore I looked at that but after looking with a flash light it was on 230 and now it powers up :slightly_smiling_face:

1 Like

This kind of font and finish is common to Creality and subsidiary products. I have the same on my Artillery X1. Terrible fit and finish. I chased the problem myself, spend more on parts than the initial cost of the printer. I eventually solved the issues but it took effetely rebuilding 90% of the printer.

My advise is stop chasing the issue contact tech support and have it replaced.

So happy to help, happy printing