X axis will not auto-home

Hi, I’ve had my M4 for a few months. It worked great at first but then I had an epic print failure overnight and the x-axis belt pulled off…Everything was messed up and it has taken me a few weeks to get it back to Almost functioning. I finally was getting OK not great prints and was adjusting the belt tension. Somehow I threw the X-axis out of alignment. When I try to get it to autohome it will not go all the way to the Left to hit the endswitch. Instead it Zero’s about the middle of the board and then tries to go beyond the right side making loud grinding noises.

I tried powering down, then tried unplugging for a few mins (worth a shot). This did nothing. I looked through all the settings and cannot find anything that will help.
I tried powering it down, moving the Extruder all the way to the left on the x-axis and turning the printer back on…still won’t do it.

I then tried a factory reset. NOTHING

I’ve googled and cannot find a single hit about how to fix this and have posted in a few help groups and all i’ve heard so far was Crickets.

I can only imagine its a software setting. I have little to no idea how to adjust settings with Pronterface other than doing the esteps.

Any ideas? Im at an impasse


Hi Kris

With the power off, does the x axis move smoothly through it’s full motion range? There shouldn’t be any tight spots and you should feel a little load as you’re moving the axis but it should be contstant all the way. Be 100% certain of this before you try it under power again. My reading of your post suggests a mechanical problem that the drive is unable to overcome.


Slides very easy with the power off. It seems to me like the printer’s memory thinks the x-axis is in a diff place than it is…i don’t understand why it doesn’t just move all the way to the right…hit the endswitch but it just won’t do it.
If i turn it off move it all the way to the left it still ends up overshooting on the right side and grinding then.

I’d take it back to first principles. Where is the grinding? At the stepper, or the tensioner? Either way I suggest you disassemble the X-axis gantry and make sure that the belt hasn’t had teeth stripped off, there’s no problems with the mating of the gear to the stepper motor, belt to the gear, etc.

Just because you can move the extruder won’t mean that you don’t have a problem with the belt. Since the teeth face inwards on the gantry you can’t easily see it (seems to be similar to the CR10-smart pro that way. No, this has never happened to me with a printer, but, the belts are flexible compound, the gears are metal…too much tension, and metal will cut compound. I did have a similar problem with a Chrysler product, where in a $50 Gator belt was the solution, but it cost me another 8K in repairs to find out I needed that $50 belt. I no longer buy Chrysler. :rage:

The X–axis moves easily and with no grinding until it gets to the far right where it is physically obstructed and THEN it makes grinding sounds when it tries to keep moving to the right.

If i move the axis through the printer it thinks the 0 point of the X-axis is in the middle of the plate not all the way to the left, and nothing I can do seems to convince the printer otherwise.

At least you know the chassis and mechanics are undamaged Kris. I was going to suggest a related test next. If you ask the printer to drive a specific distance, say 50mm, how far does it actually move?
As for how your printer knows its position, most will drive until the axis limit switch changes state. The machine then reverses a fixed number of steps and that’s how it knows where it is. If your printer isn’t able to see this switch change then it’ll carry on trying to move when it’s phyically unable to do so. Do you have a test meter to check the switch when the carriage stops?

So interestingly…i left it off for a day and just powered it back up and the issue has resolved itself. Very odd…

Glad it’s working but I still think it’s worth checking that limit switch and trying to track down what caused the failure. Intermittent faults are always the most difficult to locate so it might raise its head again.