X Y & Z Stepper Motors 'Freeze': Much Blobiness ensues

My BIQU B1 printer has started failing.


  • The X and Y stepper motors stop moving mid print or,
  • The Y stepper motor stops moving while the X continues or,
  • The X, Y and Z stepper motors stop moving.

In some cases, the extruder continues to pump material, others it stops.

I assumed something was over heating so I opened the case to check fans - all were running just fine.

This has happened occasionally over the last couple of months but now is on almost every print. I was using Octoprint previously and assumed there was an issue with my Raspberry Pi because the USB local print worked fine. Now, the USB fails, even with different USB sticks.

Anybody have thoughts on what I might try before randomly buying replacement parts?

have you tried just an sd card and not USB?

Yes, I did last night after your suggestion. Same result using two different prints.

The first print failed with the Y stepper freezing and the X continuing to run resulting in a continuous back and forth on the same line.

The second print failed with both X and Y freezing. It was late so I didn’t investigate what Z and E0 were doing.

I’m doing a test as I type with slicer set to both heaters at 20C (i.e. off), cooling fan off and filament cut after the sensor/before E0. My thought being that this might tell me if my power supply is failing to provide enough current.

if you have a multimeter you can look at the power supply directly. see what the voltage drop is when the heaters first come on from cold. I’ve heard some early B1’s had marginal power supplies and the newer ones had supposedly better “mean well brand ones”

This one has a Meanwell in it and voltage drop is less than 0.2V (24.21V to 24.05V).

The cold print also failed with X & Y frozen.

I ran a print from Octoprint and watched the terminal output. Both X & Y froze but the terminal continued to display commands and responses. The GCode Viewer continued to display progress. I think this means that the controller believed printing remains in process.

The touchscreen allowed me to Move the Z axis up and down but not X & Y.

Interestingly, I note that the last three print attempts failed at Z +0.7mm. I have not made any previous notes on fail height. Coincidentally? 0.7mm is the height set in Cura for Regular fan speed. The last two fails were with cooling disabled.

X and Y both freeze at the same time?
Every time? Is it a v1.4 board?

Sometimes X and Y, sometimes just Y. When it is X & Y, they both freeze at the same time.

For the last three days - half a dozen or so prints - all have frozen.

Over the last, say, four months, I had occasional freezes which I had attributed to Octoprint. Subsequent prints had, previous to the last few days, worked fine

Yes, a 1.4 board.

HI @GaryMachin

Welcome to the forum, So glad you found us.

Just to add something else in here, Have you checked for overheating? If the stepper drivers are getting hot they may give up on thermal shutdown. Have you checked the case fan that blows air over the stepper drivers, Was a bit of an issue when they give up random weird stuff would start happening.

I did check the case fan and it was blowing.

Just to be sure, I removed the bottom cover, propped the printer up on legs and placed an 80mm fan powered by a separate supply blowing directly at the board.

The print failed again at 0.7mm with (at least) both X & Y steppers frozen.

Is there such a thing as ‘Factory Reset’ on BIQU B1?

You can put new or older firmware on it. All versions are on github. Also the forward for the screen

Just to ask a dumb question here, Are your steppers getting hot to the touch?

The X stepper is not. Can’t comment on the Y since until yesterday’s case open test, it was enclosed.

I used the menus to reset all to defaults, recalibrated the bed and ran self level then tried a print from SD.

Can confirm that steppers are warm to the touch, not hot.

Print failed at 0.7mm. This time I was standing at the printer when it failed.

  • No messages displayed on the touchscreen
  • A small knock sound, like a stepper motor being unlocked
  • All steppers stopped. X immediately free to move manually. Y and Z locked for a number of seconds and then free to move manually.
  • Unable to turn off either heater via touchscreen
  • Tried Emergency stop via touchscreen and got the following echo:
    Unknown command: “0 X170.157 Y182M112”
    with an OK response button.

Interested in whether people think the M112 part is from my stop request or whether it is what is causing the freezes. If it is from what causes the freezes, why would the heaters remain on? Moreover, how do I get rid of it?

that is a strange message to come up, the format is not correct. Just as a dumb question have you tried a new SD card? it’s possible it may be reading a bad block on the SD and it doesn’t know what to do with it.

Just a thought, Maybe try to print from your PC over a USB cable, If that works it would pretty much eliminate the printer and lean toward the SD.

I’ve tried different SD cards and USB sticks.

I also (effectively) tried printing from a computer since I use Octoprint on a Raspberry.

I did a firmware update in the last couple of minutes - I’ll let you know how that turns out.

Good News Everyone!

The print completed. I loaded the firmware from Github dated 2021-04-28, then used the same sliced file and SD card.

I know that one completed print does not a solution make and I will report any further issues back here.

Thanks for your help and suggestions.

1 Like

Hey Gary, That’s awsome, Sorry I missed the part about you printing on Octoprint Glad it looks like you may have a solution though