Z-Axis Weirdness


Something has changed on my Spare Parts Printer and I’m damned if I can figure out what it is. The printer’s hot end is no longer able to go down to the level of the bed.

This is really strange because homing using the BL Touch is working okay and there isn’t any binding on the Z-Axis lead screws.

When I home the printer, everything works okay and the hot end goes up to 13.2mm but when I try to lower it by 1mm at a time, it works until 10.2 and then drops to around 3mm from the print surface (although the on screen height indication says that it is 9.2mm).

When I continue to go down from this point, nothing happens, but the on screen height indicator says that it is going down - when I start going up, the indicator increases until I hit 9.2 and then it jumps up again after I press up again.

I get the same behaviour when I select movements of 10mm or 0.1mm. The 10mm point triggers a movement of about 7mm and then nothing until I get back to 10mm.

Things seemed to be working fine earlier this evening but then this operation kept happening. Clearly I’ve engaged some kind of trigger point. I tried swapping out the TMC2209 drivers and I’ve rebuilt Marlin (I’m using a month old bugfix) but no luck.

Any ideas?

I’m wondering if you have a software limit set somewhere? I’m doubting this myself since it wouldn’t account for all the described behaviours, but I’m at a loss. An chance you could post a video? Also, is there any chance that a cable is hitting the Z-axis limit switch? Again, it wouldn’t explain everything, but this is a real head-scratcher.

1 Like


I’m guessing I have a software limit set somewhere, but I have no idea where it got set.

Here is a link to a crappy video showing what’s happening: 2022.03.14 - Z-Axis Weirdness Video

I’d appreciate any ideas.

Not a solution, but an experiment:

Put a thick block of wood on the build plate (or a book, or whatever), to cause the BLTouch to treat this as the new “0” point. Does the it behave the same way, only 9.2mm above the wood/book/whatever? If it does, it’s definitely a software/settings problem. Basically, I’m trying to establish if the problem takes place at a fixed point along Z or at a point relative to what the BLTouch thinks is 0.

By the way, it looks like M211 S0 will turn off software endstops, if you haven’t tried that yet.

Sorry I’ve tried that and I should have said that before. I also dismounted the BL Touch and tried it manually all with the same results.

I’ll give that a try - thanx.

Any idea how they could get set/changed?


Okay, I’ve tried and retried changing the Z value with a block of wood.

I’m using the “G28” code serially to control the printer along with “M18” (Stop Motors) and “M106 S###” to check the interface by turning on the cooling fan.

Now, following: G-code - RepRap

I’ve tried M211 without any luck in changing the behaviour.

What else should I try?


So what was the result? Did the behaviour still take place at the same absolute height, or at the same height relative to the wood?

No change in the behaviour - the same with trying M211 S0.

Sorry I wasn’t clear before.

Next steps?


I downloaded the latest Marlin bugfix and then set up the configuration/platformio files and tried it again and things seem to be working again - I’m on my second print now after making the changes.

I have no idea what happened, I don’t remember reloading the controller’s flash before the problem happened (I definitely did and rebuilt it) but I didn’t save a copy of what I downloaded so I guess I changed something inadvertently.

Thanx for your suggestions.