Z probe always open, Klipper skr pro v1.2

Having trouble with my z probe not triggering. A prusa bear with Skelestruder and skr pro v1.2 running klipper firmware. Pinda v2 probe and not using the white thermistor wire. Got sensorless homing all tuned in for x and y. Homes successfully. Tried homing z and probe does not read the plate and keeps crashing into bed. Tried holding metal to the sensor it still shows open with query end stop command. Also tried plugging into e0 endstop plug and changed pin out for that and same thing. Also tried with ^ but no change. Not sure what to try next.

step_pin: PE13
dir_pin: PC2
enable_pin: !PC0
microsteps: 32
rotation_distance: 8
endstop_pin: probe:z_virtual_endstop
position_max: 210
position_min: -2
full_steps_per_rotation: 200

[tmc2209 stepper_z]
uart_pin: PE1
run_current: 0.950
hold_current: 0.600
stealthchop_threshold: 999999

pin: PE15
samples: 3
speed: 5
sample_retract_dist: 2.0
samples_result: average
samples_tolerance: 0.025
samples_tolerance_retries: 5
z_offset: .15
y_offset: 5
x_offset: 24

home_xy_position: 125,100
speed: 60
z_hop: 10
z_hop_speed: 10

speed: 120
horizontal_move_z: 5
mesh_min: 35,10
mesh_max: 230, 190
probe_count: 5,5
mesh_pps: 3,3
algorithm: lagrange
bicubic_tension: 0.2