BL Touch doesn't work at all?

This is nuts! Yes, I watched hours of YT vids on this subject (Chris Basement, Teaching Tech & others). I reviewed similar issues on this forum and others. Even though I’ve been 3D printing for years I made the mistake of thinking it was time to upgrade my CR10-S4 with a BTT SKR v1.4Turbo, TFT35, BLTouch, Micro-Swiss Direct Extruder and filament runout. MB and TFT installs took me sometime but finally seems to be working. I am installing one item at a time and solving any issues as I go along. Now I’m trying to get the BLTouch (V3.1) working so I can do some prints on my new WhamBam surface. I installed the BLTouch (BLT) and paid VERY CLOSE attention to the wiring and keeping in mind all the information I had gathered on the subject. It doesn’t seem a complicated process or so I thought. I checked the wiring over and over to avoid magic smoke (swapped Blue & Red wires on the connector because they were setup for a Creality board not my BTT SKR v1.4 Turbo). Made all the necessary changes in Marlin Turned on the printer and waited. After about 10secs my something beeped, the BLT was flashing Red & Blue…probe did not move? There was an error message but I didn’t notice it till later. Turned power On/Off…same results? I tried to ‘deploy’ using the ‘touch’ screen, the blue LED went off and ONLY the Red was flashing. I touched ‘Reset’ which turned the blue LED back on, Red was still flashing? Noticed an error message ‘Invalid Mesh’…and…‘Failed to enable bed leveling’ on the TFT. I tried the ‘Self Test’ with exactly same results blue was off only red flashing. Hit ‘Reset’ and both LEDs were flashing. Restarted the printer and noticed the same error message right off the bat & probe didn’t move. I then move the ‘probe’ connector to the Z min endstop. Configured Marlin accordingly, updated firmware on MB. Results…exactly the same error message, LEDS, no probe movement. Moved ‘probe’ connection back to its proper location on the MB, plugged ‘Z’ endstop back in, changed Marlin, updated firmware changes to MB. Results…exactly the same error message, LEDS, no probe movement. 3 wires from BLT are Blue (Gnd), Red (Pwr), Yellow (Sig), 2 probe wires Black (Gnd) and White (Sig). Sorry if my text is long but wanted to provide important criteria. My brain is overloaded with BLTouch/Marlin/BTT TFT35/SKR info and now I don’t know where to turn. I did check this forum thoroughly and clicked on different links, watched vids all to no avail. I’m so disappointed and frustrated that something so simple turns into a nightmare. I’m sure my problem is somewhere in Marlin. Any suggestions are welcomed.

HI @Rotorfreak

I can understand your frustration, The Flashing red on the BLtouch is an internal error saying that its not being “poked” properly by the firmware.

I have a pic somewhere of the wiring for the BLtouch on the SKR give me a moment and I will post it up here.

If you scroll through the manual Section 4 specifies BLTOUCH and wiring into the board.

Depends on how you have the firmware setup, If you have it setup so you use “zMin as probe trigger” you will have to change the Black and white wires to the Z min input on the board. If you do not use the ZMIN input you can setup as a standard probe.

Hope this helps

Hi Jason, actually, I have that manual on my laptop and referred to it during my install. Since the start of these problems I’ve reviewed what I’ve done so many times that I’m afraid the issue is staring me in the face and I’m blind to it. I think I’ll just remove all my changes in Marlin related to the BLTouch and start over. Maybe I’ll use the Marlin ‘bugfix’ edition. Keep those suggestions comin! Be safe everyone.

Don’t know if you’ve noticed this. The lights can indicate certain faults the brightness of the blue and the speed of the red flashing.

Also Mine had probing errors because the probe wouldn’t extend on time. I cleaned it and adjusted it with the set screw in the top

Hi Glenn, yes I saw that, wasn’t it from this forum under another title? I did check the wiring and know it is correct. From what I’ve seen on YT about my motherboard SKR v1.4Turbo it is okay to use the ‘Z’ Min Stop and BLTouch. So you can ‘home’ to the front left and then do a bed leveling with the probe. Ref the following video at the 20:40 mark! BLtouch Bed Leveling Sensor - Everything Install - Chris's Basement - YouTube He uses the Servo and Probe connections and RETAINS the ‘Z’ endstop. I will try to interpret the led flashes tomorrow. I still think my problem is Marlin related but what? Gotta try and sleep on this one! Appreciate your attention and feedback.

I posted this before here somewhere but the diagram is from the BLtouch3.1 manual

So here’s what I noticed. I turn on the printer and only the RED led comes on flashing 20 times then changes to a steady lite and the BLUE led comes on. So they’re both on with steady lights. If I do a ‘Deploy’ (via Marlin menu) ONLY the RED led flashes which gradually increases in speed. The BLUE led is OFF. When I click ‘Reset’ both the Blue and RED leds go back to a steady light no flashing. So IMHO it MUST be getting some kind of signal or these leds wouldn’t change at all? It also still displays the same error messages as before. “Invalid Mesh” and “Failed to Enable Bed Leveling”. It strikes me as it is trying to execute commands BEFORE it finished booting up!? I’m still stumped.

And the saga continues. I checked the LEDs light sequencing & couldn’t figure out anything special except that the BLT wasn’t working. Then I remembered having an issue with my printer only traveling half my bed dimensions even though these were all correctly entered in Marlin. I spent many hours trying to figure out WHY I was only getting HALF the travel distances even though properly setup in Marlin?? To make a long story short the BigTreeTech TFT35 has its’ own CONFIG.ini. It also has bed dimensions and they were set to HALF my bed size!! They say the TFT checks MARLIN and reacts appropriately. That’s BS because as soon as I fixed those dimensions in the TFT config.ini my printer travels were perfect!! I noticed that in TFT ‘Marlin Mode’ it moved according to what is set in Marlin but when switching to the ‘Touchscreen’ it did NOT!! Hmmmm…food for thought. So back to my BLTouch issue. I checked the TFT config.ini file which seemed okay but I made some minor changes and at the same time I uninstalled the BLTouch to check its authenticity and to see if the wires were identified on the unit. Everything checked out okay. I reinstalled the BLTouch and turned on the printer. MY JAW HIT THE FLOOR!! The BLTouch did its’ test deploy & stow 2 times!! IT NEVER DID THAT BEFORE. I turned off the printer and turned it on and it deployed again. HOLY COW!! I was so happy and freaked out…I’m finally getting somewhere. So I took a break to eat lunch and afterwards turned on the printer again and NO DEPLOYMENT TEST??? WTF!!! It reverted right back to its flashing again?? So I spent the whole afternoon making small changes to the TFT config.ini with no results. So I gently and carefully pulled the probe down, then stowed it, and turned on the printer and IT WORKED!!! Tested several times afterwards and it did its little test deploying 2x’s. It then failed again so I manually deployed and stowed the probe turned the printer on and it worked again!! So the problem doesn’t seem to the Marlin nor TFT config files settings. It seems more like it has to do with the BLTouch itself even though the probe moves VERY easily. I checked the AntClabs site and found UPDATED config files for the BLTouch. The new TFT config file works ONLY with the new Marlin so I checked and downloaded the revised Marlin software. I had been using Marlin Now I’ve got to go through all the settings again then update the firmware to both my Motherboard and TFT display. Just wanted to give you guys a follow-up to this stupidity. Please be aware the BTT TFT35 seems to have bugs in ‘touch mode’. I will provide more info once the new firmwares which will hopefully address these bugs are installed.

1 Like

Have you pulled the probe out? it sounds like it’s stuck. if it doesn’t deploy in time it’ll error out. I took mine out cleaned a tiny bit of mold flash off it and it’s worked 100% ever since.

@Rotorfreak Thanks for keeping us updated, I’m more than confused by the problem you are running into. never seemed to have that much issue with a BLTouch.

Just to ask an odd question, have you enabled or have you tried “software” mode for the BLtouch. I know there was a version of them that would not work reliably at all unless it was set to on.

Glenn, yup, I pulled it out by hand, it deployed & stowed very easily, didn’t seem ‘stuck’ which is something I was watching for. No resistance at all. I didn’t remove it completely. Do we remove the little allen bolt at the top of the BLT in order to extract the probe? The following statement is from the Antclab site;
※ The action as pulling/pushing hard the push-pin can make the BLTouch damaged and less accuratte.

※ If push-pin down error occurs, turn core 180 degrees with Allen-key so that the core is further inside the casing.
I might remove the probe and clean it with alcohol as a precaution.

Jason, I agree. I had done a lot of research on how the BLT worked and was installed prior to buying one. My decision to install a BLT has caused this whole frustrating event. My printer used to work perfectly…I expected maybe some minor problems during installation but NOT this.
Don’t worry, I’ll follow-up once the firmware is updated, fingers crossed. BTW, I’m not familiar with ‘software’ mode with the BLTouch? Where is that? In Marlin config or on the TFT config?

It’s basically held up by magnet and the forces are not strong so if you do something that bends it it will need a new probe

I think the voltage changed with the newer bl touch modules. I had a similar problem. Found a teaching tech video on it I believe. Are you using the probe or the z stop port on the board?

I tried both options on the MB and am now back using the probe port and ‘z’ minstop. Adjusted Marlin to suit.

I think this is the video

Yeah, I saw this video along with hrs and hrs of subjects from the TFT, SKR, Marlin, BLTouch and so many more which is why I can’t believe my difficulties? Thanks for the link anyway.

yes it is a special more “positive” trigger mode for the BLtouch. I have only ever had to use it one time on an ender 3 pro. It was kind of a frustrating deal like you are seeing but it did fix it in my situation.

I may have a solution for you! if you haven’t found one yet.
I had the exact same problem you described. And for 3 days it drove me crazy. After tens of forums (which is why I found this post), tens of videos, tens of docs and trying everything I finally got it to work. My problem was that the bltouch would get in error mode (red light flashing) but seemingly randomly.
After lots of testing I realized that it got in error mode when it was trying to deploy the probe but couldn’t (even though I can pull easily the probe by hand). My understanding is that the probe has a magnet which sticks to the set screw when it’s stowed (which keeps it stowed). To deploy, the bltouch magnetizes the coil in the neck with an inverse magnetic field which overcome the magnet attraction to the set screw. But for some reason sometimes randomly the coil is not powerful enough to deploy. I know this because I can see the red light slightly diming when it tries to deploy but can’t, meaning that it uses power for the coil. And also if I manually pull the probe it would work for some cycles but then would get stuck again.

The last few things I did before it finally worked was
-make sure all the wiring is correct (which from what you said you already did)
-remove the metal pin from all the connectors and slightly tighten them with pliers, just so that I know it’s not a problem of loose connectors.
-remove the set screw, with Isopropyl alcohol clean the probe and set screw (to reduce the stickiness)
-I made some spacers (between the probe and the set screw so that the magnetic field keeping it stowed would be weaker to overcome by the coil) from masking tape by cutting a couple of disc shape the size of the set screw. Then put the probe back into the bltouch, then the spacers then the set screw. (I really don’t know if it helped so try this last.)
-finally, I unscrewed slightly the set screw. Initially the set screw was flush with the top of the bltouch. And on several sites including Antclabs, it said to tighten by increments of 90-180degree the screw so that it is more inside the bltouch. which I tried, it would help a little but never fully fix the issue. So instead I unscrewed the set screw so that it is slightly outside the top of the bltouch by 1-2 mm

It finally works! I did 5 bed leveling of 7x5 points and it hasn’t failed once. (it would usually fail after 5-6 probing)
Hope this can help you

1 Like

Hi Hergehen, like you, I watched YT videos on the subject and check MANY links to documents and noted the same info from the Antclab site about the probe screw. I also agree with your observations, once in a while it gets stuck even though the probe is very free to move. I believe your 100% right, there’s slight excess voltage holding the probe back…is that because they increased the probe ‘stroke’. This past weekend I downloaded and installed the LATEST BTT TFT35 and MARLIN firmware. I turned the printer on and the probe did its’ test and seems to be very consistent. It now always tests itself when I turn it on. Did the newly revised firmwares fix this excess voltage to the probe so it would operate correctly?? The latest Marlin version seems to include many fixes and some changes include an additional serial port. Anyway, your feedback is VERY encouraging to read and only reinforces my observations. After the firmware updates, the printer finally seems to be working as it should. Today, I’ll be verifying my bed calibrations and ‘Z’ offset, if all goes well I’ll do some test prints. If the probe acts up again, I’ll remove and clean the probe, I’ll also loosen the screw rather than tightening. Again, your feedback put a smile on my face so “Thank you” for that. Also, thanks to everyone for taking the time and giving me ‘food for thought’ on this topic. I think I’m finally making progress here. Take care everyone and be safe.

1 Like