BLTouch not probing bed

Okidoki. I’ve a BLTouch installed on my Ender-5 Pro, wired up as the Z Endstop as per Teaching Tech’s instrucitons, running Marlin 2.-something-bugfix, and everything worked fine for ages, until suddenly it just stopped deploying. There was no obvious issue, it just wouldn’t work when I started the next print.

The probe had previously gotten kinked from a collision so I thought it might just be stuck. Trying to straighten it, I broke the probe! Oh no! But I managed to fins a store in YEG that sold spares, so yesterday got a new probe. Today I put it in did a couple test deploys, all was good. Then It stopped deploying after I re-mounted it. Ack!

A reddit thread suggested the grubscrew might be too loose, so after a couple attempts at tightening that I’ve got it so the probe will stow, deploy, self-test, and auto-home properly. Hooray!

However, when use the menus to LEvel Bed, it doesn’t work. The printer homes properly, including using the BLTouch at the centre of the print bed to home z; then it moves to the first probing position, brings the bed up almost high enough to contact the probe… and then it moves the bed back down, tries once more, and signals “STOPPED” on the screen.

I’ve cycled the power repeatedly. I also thought the problem might be too large of a zed offset, now that I’ve got a new probe (though really I expected the “not bent in the middle” probe to be longer) so I ran through the Zed Offset Wizard and got it set okay with the paper test. But it’s still doing the exact same thing.

I haven’t reseated the wires yet, partly because that’s a pain in the butt. Also, the z-homing is working, which implies that the BLTouch is able to get a reading… unless bringing the printhead all the way up to the corner is breaking a connexion?

Any suggestions?


Some additional information: If I try to print something, the printer will home properly, then do the “go to probe point 1, not actually touch the probe, stop there” thing, and then will actually proceed to do the print. Alas, it then digs the nozzle into the print bed.

I don’t know if ramming the nozzle into the bed is connected to the “not probing” issue or just that my z offset is wrong; I reached the “aah I want to smash this with a hammer” stage before I could really do anything to correct the zed offset, so I don’t have enough data.

I do know that the corner for the first probe point is slightly lower than other parts of the bed, if that might be part of the problem?

Also, I found this on Reddit:

OK, I HAD this happen to me as well on a custom and a Jyers. How I fixed it was like this. You notice the mesh is non existent correct… go into manual leveling. What you will notice is look at where your probe is and then look at what its reading you may be at 1-4 but its showing 0-3. Go to where your regular 0-0 is. Then go into the Y and X axis change them to where they read 0-0. You can then go one at time hit next point. Set it up so it reads correctly when there. Etc… once you are done and at 4-4… you will have a mesh reading. Then set your z stop. And go to auto level if wanted

Which seems to be on point, but I don’t actually understand what the poster is suggesting be done.

Please help.

Bumping this up in case anyone feels like offering a suggestion.

Or even sympathy, because while I appreciate folks might not have ideas, maan is it hard feeling ignored.

I don’t have any brilliant solution for you unfortunately.

Out of curiosity when it tries to probe the first point is it deploying the pin, moving the bed up, then stopping before touching the pin and the pin is staying deployed?

What happens if you do mesh bed levelling through the menu and not at the start of a print?

Out of curiosity when it tries to probe the first point is it deploying the pin, moving the bed up, then stopping before touching the pin and the pin is staying deployed?

Yes, exactly.

The problem occurs whether I trigger the bed leveling through the menu or via a print; actually, I first noticed it with the menu, because I installed the new probe and then said “let’s make sure this works” and triggered the “Level Bed” commend from the menu.

I’ve been poking at that reddit post I quoted, and it looks like they’re saying to do a manual mesh level. So I’ve been poking at what that is, and I think I’ll need to redo the firmware to uncomment some stuff to have that as an option. Which isn’t hard, exactly, but is one of those things I do so rarely I need to relearn it every time.

Before I try that, though, I’m going to try re-initialising the EEPROM. Maybe it’s analogous to when a 2d printer gets a bad PCL packet. :confused:

And of course, now I’m worried I may have damaged my nozzle and I’m not sure I have spares. Part of me wants to just pack up the entire 3d printing idea until the Prusa XL ships…

Anyway, I really do appreciate the reply. Having someone to help brainstorm is very welcome.

The fact that it always homes properly but can’t do ABL makes me think think it’s a firmware thing and not a hardware issue unless the cable is getting pulled when it moves to the first mesh position.

I haven’t encountered this issue before, it certainly is an odd one. I bet you’re on the right track with reinitializing the eeprom then moving on to flashing firmware. At least those solutions are free to try.

The touch is getting power? Just stupid is it on questions… Did you contact Ant Labs? I found them to be very helpful when I was having issues.

The touch is getting power? Just stupid is it on questions… Did you contact Ant Labs? I found them to be very helpful when I was having issues.

Those are good questions, as it’s super easy to overlook the obvious when one is frustrated.

However, yes, it has power throughout the process, and both performs its self-test fine and works as the Z endstop when homing. So I agree with Blair that the problem feels more firmware than hardware related.

I did not think to reach out to Ant Labs, so that is also a good suggestion. Thank you for making it!

Initialising the EEPROM didn’t help, alas. I haven’t tackled the firmware yet. Today work sucked steaming monkey feces, so I’m going to spend the evening eating pizza and watching TV; which means next steps on this are tomorrow’s problem.

So, bit of an update here.

Researching the changes needed to implement manual mesh leveling, I decided to try UBL instead. After a bit of faffing about to get the firmware changed, (and man am I glad I typed that sentence because it reminded me the SD card with the .bin was still in the printer and I do not need that resetting my z offset the next time I power up) I got it installed and started running the mesh probe.

And it did the same behaviour! Raising the bed, not quite contacting the probe, dropping the bed again, and reporting “probe failed.”

My Z offset was set to -4mm, just as a default, so I tried changing it to 0.1 instead. And this time, it worked! (Yes, +0.1, because I typed the wrong thing into the command console.)

There then ensued more difficulty than I usually have fiddling the Z offset into a correct number. It’s finally ended up at -0.55, which is more than 3mm different from what it was before I replaced the probe. Weird!

This does imply that if I’d set my z offset to 0 with the bilinear ABL setup it might have worked. I thought I tried that, but maybe I didn’t? I do know that at one point I tried just running a test print without levelling, and the Z offset was set really small during that attempt, and it didn’t work - I have a bunch of lovely gouges in my garrolite bed as a result. :frowning:

So I dunno. In some ways I’ve solved this the way Indiana Jones wins a swordfight, but I’ve successfully put plastic on the print bed. Yay! There’s still a bunch of fine-tuning to do, but the core problem seems to be solved, and that’s very much a relief.